summaryrefslogtreecommitdiffstats
path: root/games/pysolfc/pysolfc.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/pysolfc/pysolfc.SlackBuild')
-rw-r--r--games/pysolfc/pysolfc.SlackBuild28
1 files changed, 20 insertions, 8 deletions
diff --git a/games/pysolfc/pysolfc.SlackBuild b/games/pysolfc/pysolfc.SlackBuild
index 1c8b838b4b..50886fe3dd 100644
--- a/games/pysolfc/pysolfc.SlackBuild
+++ b/games/pysolfc/pysolfc.SlackBuild
@@ -4,10 +4,15 @@
# Originally written by Matthew "mfillpot" Fillpot.
-# Now maintained by B. Watson <yalhcru@gmail.com>
+# Now maintained by B. Watson <urchlay@slackware.uk>
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20231216 bkw: update for v2.21.0 (and cardset-minimal 2.2.0),
+# fix broken permissions for cardsets.
+
+# 20230111 bkw: update for v2.18.0 (and cardset-minimal 2.1.0).
+
# 20211228 bkw: update for v2.14.1.
# - relicensed as WTFPL with permission from Matthew.
# - we now use python3 and -current's python-pillow, no need for
@@ -32,16 +37,16 @@
# - Include all_games.html in the docdir (with fixed paths for the links).
# - Update README and slack-desc.
-SRCNAM=PySolFC
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pysolfc
-VERSION=${VERSION:-2.14.1}
+SRCNAM=PySolFC
+VERSION=${VERSION:-2.21.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-CARDSETVER=${CARDSETVER:-2.0}
+CARDSETVER=${CARDSETVER:-2.2.0}
CARDSETS=$SRCNAM-Cardsets--Minimal-$CARDSETVER
if [ -z "$ARCH" ]; then
@@ -63,18 +68,25 @@ OUTPUT=${OUTPUT:-/tmp}
set -e
+# 20230111 bkw: upstream starting using "pysol-x.x.x" for the tag.
+# handle either name for the tarball, because I probably want to keep
+# running the old version.
+TARBALL=$CWD/$SRCNAM-$PRGNAM-$VERSION.tar.gz
+[ -e $TARBALL ] || TARBALL=$CWD/$SRCNAM-$VERSION.tar.gz
+TARDIR=$( basename $TARBALL .tar.gz )
+
fixperms() {
chown -R root:root $1
- find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ find -L $1 -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
}
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.?z
-cd $SRCNAM-$VERSION
+rm -rf $TARDIR
+tar xvf $TARBALL
+cd $TARDIR
fixperms .
# do not use 'make install', it has no way to pass --root to setup.py.