summaryrefslogtreecommitdiffstats
path: root/games/pysolfc/pysolfc.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/pysolfc/pysolfc.SlackBuild')
-rw-r--r--games/pysolfc/pysolfc.SlackBuild38
1 files changed, 28 insertions, 10 deletions
diff --git a/games/pysolfc/pysolfc.SlackBuild b/games/pysolfc/pysolfc.SlackBuild
index 67e9aec954..9347dd69bf 100644
--- a/games/pysolfc/pysolfc.SlackBuild
+++ b/games/pysolfc/pysolfc.SlackBuild
@@ -2,13 +2,31 @@
# Slackware build script for pysolfc
-# Written by Wade Nelson (wade.nels@gmail.com)
+# Copyright 2009 Matthew "mfillpot" Fillpot
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=PySolFC
PKGNAM=pysolfc
VERSION=${VERSION:-1.1}
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CARDSETS=$PRGNAM-Cardsets-$VERSION
@@ -24,7 +42,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar jxvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
@@ -35,21 +53,21 @@ find . \
## Upstream left a file out of the tarball:
## http://sourceforge.net/forum/forum.php?thread_id=1847958&forum_id=503709
-cp $CWD/pysolfc.glade data/
+cp $CWD/pysolfc.glade data
-python setup.py build
python setup.py install --root $PKG
mkdir -p $PKG/usr/man/man6
-cat docs/pysol.6 > $PKG/usr/man/man6/pysol.6 && gzip $PKG/usr/man/man6/pysol.6
+cat docs/pysol.6 > $PKG/usr/man/man6/pysol.6 ; gzip $PKG/usr/man/man6/pysol.6
+
mkdir -p $PKG/usr/share/applications
cat $CWD/$PKGNAM.desktop > $PKG/usr/share/applications/$PKGNAM.desktop
## Are we installing extra cardsets?
if [ -e $CWD/$CARDSETS.tar.bz2 ]; then
- echo -e "Extracting extra cardsets (this may take some time)..."
- ( cd $TMP && tar jxf $CWD/$CARDSETS.tar.bz2 )
- cp -a $TMP/$CARDSETS/* $PKG/usr/share/$PRGNAM/
+ echo -e "Extracting extra cardsets (this may take some time)..."
+ tar xf $CWD/$CARDSETS.tar.bz2 -C $TMP
+ cp -a $TMP/$CARDSETS/* $PKG/usr/share/$PRGNAM/
fi
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
@@ -61,4 +79,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PKGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PKGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}