summaryrefslogtreecommitdiffstats
path: root/games/redeclipse
diff options
context:
space:
mode:
Diffstat (limited to 'games/redeclipse')
-rw-r--r--games/redeclipse/Makefile.patch128
-rw-r--r--games/redeclipse/README10
-rw-r--r--games/redeclipse/doinst.sh9
-rw-r--r--games/redeclipse/redeclipse.SlackBuild103
-rw-r--r--games/redeclipse/redeclipse.info10
-rw-r--r--games/redeclipse/slack-desc19
6 files changed, 279 insertions, 0 deletions
diff --git a/games/redeclipse/Makefile.patch b/games/redeclipse/Makefile.patch
new file mode 100644
index 0000000000..afb6063328
--- /dev/null
+++ b/games/redeclipse/Makefile.patch
@@ -0,0 +1,128 @@
+--- Makefile.orig 2012-08-30 23:59:06.000000000 -0600
++++ Makefile 2012-12-24 13:15:46.139736132 -0700
+@@ -1,9 +1,10 @@
+ APPNAME=redeclipse
++VERSION=@VERSION@
+ APPCLIENT=reclient
+ APPSERVER=reserver
+
+ #CXXFLAGS= -ggdb3
+-CXXFLAGS= -O3 -fomit-frame-pointer
++CXXFLAGS= $(EXTRA_CXXFLAGS) -fomit-frame-pointer
+ override CXXFLAGS+= -Wall -fsigned-char -fno-exceptions -fno-rtti
+
+ PLATFORM= $(shell uname -s)
+--- system-install.mk.orig 2012-08-13 04:51:04.000000000 -0600
++++ system-install.mk 2012-12-24 13:39:56.896599172 -0700
+@@ -3,15 +3,15 @@
+ cappname=$(shell echo $(appname) | tr '[:lower:]' '[:upper:]')# Captial appname
+ appclient=$(APPCLIENT)
+ appserver=$(APPSERVER)
+-prefix=/usr/local
++prefix=/usr
+ games=
+ gamesbin=/bin
+ bindir=$(DESTDIR)$(prefix)/bin
+ gamesbindir=$(DESTDIR)$(prefix)$(gamesbin)
+-libexecdir=$(DESTDIR)$(prefix)/lib$(games)
+-datadir=$(DESTDIR)$(prefix)/share$(games)
+-docdir=$(DESTDIR)$(prefix)/share/doc
+-mandir=$(DESTDIR)$(prefix)/share/man
++libexecdir=$(DESTDIR)$(prefix)/libexec
++datadir=$(DESTDIR)$(prefix)/share/games/$(appname)
++docdir=$(DESTDIR)$(prefix)/doc/$(appname)-$(VERSION)
++mandir=$(DESTDIR)$(prefix)/man
+ menudir=$(DESTDIR)$(prefix)/share/applications
+ icondir=$(DESTDIR)$(prefix)/share/icons/hicolor
+ pixmapdir=$(DESTDIR)$(prefix)/share/pixmaps
+@@ -45,55 +45,55 @@
+ icons: $(ICONS)
+
+ system-install-client: client
+- install -d $(libexecdir)/$(appname)
++ install -d $(libexecdir)
+ install -d $(gamesbindir)
+- install -m755 $(appclient) $(libexecdir)/$(appname)/$(appname)
++ install -m755 $(appclient) $(libexecdir)/$(appname)
+ install -m755 install/nix/$(appsrcname).am \
+ $(gamesbindir)/$(appname)
+- sed -e 's,@LIBEXECDIR@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
+- -e 's,@DATADIR@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
+- -e 's,@DOCDIR@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
++ sed -e 's,@LIBEXECDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
++ -e 's,@DATADIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
++ -e 's,@DOCDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
+ -e 's,@APPNAME@,$(appname),g' \
+ -i $(gamesbindir)/$(appname)
+- ln -s $(patsubst $(DESTDIR)%,%,$(datadir))/$(appname)/data \
+- $(libexecdir)/$(appname)/data
++ ln -s $(patsubst $(DESTDIR)%,%,$(datadir))/data \
++ $(libexecdir)/data
+
+ system-install-server: server
+- install -d $(libexecdir)/$(appname)
++ install -d $(libexecdir)
+ install -d $(gamesbindir)
+ install -m755 $(appserver) \
+- $(libexecdir)/$(appname)/$(appname)-server
++ $(libexecdir)/$(appname)-server
+ install -m755 install/nix/$(appsrcname)-server.am \
+ $(gamesbindir)/$(appname)-server
+- sed -e 's,@LIBEXECDIR@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
+- -e 's,@DATADIR@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
+- -e 's,@DOCDIR@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
++ sed -e 's,@LIBEXECDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
++ -e 's,@DATADIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
++ -e 's,@DOCDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
+ -e 's,@APPNAME@,$(appname),g' \
+ -i $(gamesbindir)/$(appname)-server
+
+ system-install-data:
+- install -d $(datadir)/$(appname)
+- cp -r ../data $(datadir)/$(appname)/data
++ install -d $(datadir)
++ cp -r ../data $(datadir)/data
+
+ system-install-docs: $(MANPAGES)
+ install -d $(mandir)/man6
+- install -d $(docdir)/$(appname)
+- sed -e 's,@LIBEXECDIR@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
+- -e 's,@DATADIR@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
+- -e 's,@DOCDIR@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
++ install -d $(docdir)
++ sed -e 's,@LIBEXECDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
++ -e 's,@DATADIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
++ -e 's,@DOCDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
+ -e 's,@APPNAME@,$(appname),g' \
+ -e 's,@CAPPNAME@,$(cappname),g' \
+ ../doc/man/$(appsrcname).6.am | \
+ gzip -9 -n -c > $(mandir)/man6/$(appname).6.gz
+- sed -e 's,@LIBEXECDIR@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
+- -e 's,@DATADIR@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
+- -e 's,@DOCDIR@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
++ sed -e 's,@LIBEXECDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
++ -e 's,@DATADIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
++ -e 's,@DOCDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
+ -e 's,@APPNAME@,$(appname),g' \
+ -e 's,@CAPPNAME@,$(cappname),g' \
+ ../doc/man/$(appsrcname)-server.6.am | \
+ gzip -9 -n -c > $(mandir)/man6/$(appname)-server.6.gz
+- cp -r ../doc/examples $(docdir)/$(appname)/examples
+- cp ../doc/guidelines.txt $(docdir)/$(appname)/guidelines.txt
++ cp -r ../doc/examples $(docdir)/examples
++ cp ../doc/guidelines.txt $(docdir)/guidelines.txt
+
+ system-install-menus: icons
+ install -d $(menudir)
+@@ -103,9 +103,9 @@
+ install -d $(icondir)/64x64/apps
+ install -d $(icondir)/128x128/apps
+ install -d $(pixmapdir)
+- sed -e 's,@LIBEXECDIR@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
++ sed -e 's,@LIBEXECDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
+ -e 's,@DATADIR@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
+- -e 's,@DOCDIR@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
++ -e 's,@DOCDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
+ -e 's,@APPNAME@,$(appname),g' \
+ install/nix/$(appsrcname).desktop.am > \
+ $(menudir)/$(appname).desktop
diff --git a/games/redeclipse/README b/games/redeclipse/README
new file mode 100644
index 0000000000..a9b471784b
--- /dev/null
+++ b/games/redeclipse/README
@@ -0,0 +1,10 @@
+Red Eclipse (Fast-paced futuristic FPS)
+
+Red Eclipse is a single-player and multi-player first-person
+ego-shooter, built as a total conversion of Cube Engine 2, which lends
+itself toward a balanced gameplay, completely at the control of map
+makers, while maintaining a general theme of agility in a variety of
+environments.
+
+This package is a re-build rather than a re-packaging of the
+Red Eclipse release, respecting your custom SLKCFLAGS.
diff --git a/games/redeclipse/doinst.sh b/games/redeclipse/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/games/redeclipse/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/redeclipse/redeclipse.SlackBuild b/games/redeclipse/redeclipse.SlackBuild
new file mode 100644
index 0000000000..5ea869cdec
--- /dev/null
+++ b/games/redeclipse/redeclipse.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/sh
+
+# Slackware build script for Red Eclipse
+
+# Copyright 2012 Erik Falor USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=redeclipse
+VERSION=${VERSION:-1.3.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM
+tar xvf $CWD/${PRGNAM}_${VERSION}_nix_bsd.tar.bz2
+cd $PRGNAM
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# remove the pre-built binaries
+rm -f bin/* bin64/*
+
+# Compile the application using custom SLKCFLAGS
+(
+ cd src
+ cp ../doc/man/cube2font.1 install/nix
+
+ # Hack makefiles so Red Eclipse is installed into the folders we specify
+ # and to respect SLKCFLAGS
+ sed -e "s,@VERSION@,$VERSION," $CWD/Makefile.patch | patch -b
+
+ make EXTRA_CXXFLAGS="$SLKCFLAGS" all cube2font
+ make DESTDIR=$PKG system-install system-install-cube2font
+)
+
+# Copy program documentation into the package
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/all-licenses.txt doc/cc-by-sa.txt doc/changelog.txt doc/cube2font.txt \
+ doc/license.txt doc/trademark.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+
+# Copy slack-desc and doinst.sh into ./install
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+# Make the package; be sure to leave it in $OUTPUT
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/redeclipse/redeclipse.info b/games/redeclipse/redeclipse.info
new file mode 100644
index 0000000000..c871263ffe
--- /dev/null
+++ b/games/redeclipse/redeclipse.info
@@ -0,0 +1,10 @@
+PRGNAM="redeclipse"
+VERSION="1.3.1"
+HOMEPAGE="http://www.redeclipse.net"
+DOWNLOAD="http://downloads.sourceforge.net/redeclipse/redeclipse_1.3.1_nix_bsd.tar.bz2"
+MD5SUM="7b320932965e61bf14ad115ac6f6e94b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Erik Falor"
+EMAIL="ewfalor@gmail.com"
diff --git a/games/redeclipse/slack-desc b/games/redeclipse/slack-desc
new file mode 100644
index 0000000000..ca83c5becb
--- /dev/null
+++ b/games/redeclipse/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+redeclipse: Red Eclipse (Fast-paced futuristic FPS)
+redeclipse:
+redeclipse: Red Eclipse is a single-player and multi-player first-person
+redeclipse: ego-shooter, built as a total conversion of Cube Engine 2, which lends
+redeclipse: itself toward a balanced gameplay, completely at the control of map
+redeclipse: makers, while maintaining a general theme of agility in a variety of
+redeclipse: environments.
+redeclipse: This package is a re-build rather than a re-packaging of the
+redeclipse: Red Eclipse release, respecting your custom SLKCFLAGS.
+redeclipse:
+redeclipse: homepage: http://www.redeclipse.net