summaryrefslogtreecommitdiffstats
path: root/games/stratagus
diff options
context:
space:
mode:
Diffstat (limited to 'games/stratagus')
-rw-r--r--games/stratagus/README13
-rw-r--r--games/stratagus/stratagus.SlackBuild18
-rw-r--r--games/stratagus/stratagus.info4
3 files changed, 23 insertions, 12 deletions
diff --git a/games/stratagus/README b/games/stratagus/README
index cac5260373..f87254c060 100644
--- a/games/stratagus/README
+++ b/games/stratagus/README
@@ -1,12 +1,13 @@
stratagus (RTS game engine)
Stratagus Core is a free cross-platform real-time strategy gaming
-engine. It includes support for playing over the internet/LAN, or playing
-a computer opponent. The engine is configurable and can be used to create
-games with a wide range of features specific to your needs.
+engine. It includes support for playing over the internet/LAN, or
+playing a computer opponent. The engine is configurable and can be
+used to create games with a wide range of features specific to your
+needs.
-If you're installing stratagus as a dependency for wargus, make sure the
-stratagus and wargus version numbers match. This shouldn't be a problem
-(both will be updated at SBo at the same time, when needed).
+If you're installing stratagus as a dependency for wargus, make sure
+the stratagus and wargus version numbers match. This shouldn't be a
+problem (both will be updated at SBo at the same time, when needed).
Stratagus was formerly known as FreeCraft and ALE Clone.
diff --git a/games/stratagus/stratagus.SlackBuild b/games/stratagus/stratagus.SlackBuild
index 09450f4443..99b74a19c2 100644
--- a/games/stratagus/stratagus.SlackBuild
+++ b/games/stratagus/stratagus.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for stratagus
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
@@ -27,10 +27,13 @@
# 20180915 bkw: updated for v2.4.1
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=stratagus
VERSION=${VERSION:-2.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -40,7 +43,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -75,6 +82,9 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
# share/doc/$PRGNAM, so:
sed -i "s,share/doc/$PRGNAM,doc/$PRGNAM-$VERSION," CMakeLists.txt
+# 20211119 bkw: fix compile with -current's gcc.
+sed -i 's,"_C_," _C_,' src/ai/ai_plan.cpp src/stratagus/script.cpp
+
mkdir -p build
cd build
cmake \
@@ -106,4 +116,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/games/stratagus/stratagus.info b/games/stratagus/stratagus.info
index e86bc61b48..d5cfe03044 100644
--- a/games/stratagus/stratagus.info
+++ b/games/stratagus/stratagus.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/Wargus/stratagus/archive/v2.4.1/stratagus-2.4.1.tar
MD5SUM="ad8d49e4e19d8de49b5a8241d1b0ab7b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="tolua++ libmikmod fluidsynth"
+REQUIRES="tolua++ libmikmod"
MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
+EMAIL="urchlay@slackware.uk"