summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/pysolfc/README2
-rw-r--r--games/pysolfc/pysolfc.SlackBuild38
-rw-r--r--games/pysolfc/pysolfc.info8
-rw-r--r--games/pysolfc/slack-desc4
4 files changed, 35 insertions, 17 deletions
diff --git a/games/pysolfc/README b/games/pysolfc/README
index ddc7c41c25..602a3313ba 100644
--- a/games/pysolfc/README
+++ b/games/pysolfc/README
@@ -9,5 +9,3 @@ decide to add them later, they can be extracted to ~/.PySolFC/cardsets
The extra cardsets tarball is available here:
http://downloads.sourceforge.net/pysolfc/PySolFC-Cardsets-1.1.tar.bz2
-
-PySolFC requires pil from SlackBuilds.org.
diff --git a/games/pysolfc/pysolfc.SlackBuild b/games/pysolfc/pysolfc.SlackBuild
index 67e9aec954..9347dd69bf 100644
--- a/games/pysolfc/pysolfc.SlackBuild
+++ b/games/pysolfc/pysolfc.SlackBuild
@@ -2,13 +2,31 @@
# Slackware build script for pysolfc
-# Written by Wade Nelson (wade.nels@gmail.com)
+# Copyright 2009 Matthew "mfillpot" Fillpot
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=PySolFC
PKGNAM=pysolfc
VERSION=${VERSION:-1.1}
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CARDSETS=$PRGNAM-Cardsets-$VERSION
@@ -24,7 +42,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar jxvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
@@ -35,21 +53,21 @@ find . \
## Upstream left a file out of the tarball:
## http://sourceforge.net/forum/forum.php?thread_id=1847958&forum_id=503709
-cp $CWD/pysolfc.glade data/
+cp $CWD/pysolfc.glade data
-python setup.py build
python setup.py install --root $PKG
mkdir -p $PKG/usr/man/man6
-cat docs/pysol.6 > $PKG/usr/man/man6/pysol.6 && gzip $PKG/usr/man/man6/pysol.6
+cat docs/pysol.6 > $PKG/usr/man/man6/pysol.6 ; gzip $PKG/usr/man/man6/pysol.6
+
mkdir -p $PKG/usr/share/applications
cat $CWD/$PKGNAM.desktop > $PKG/usr/share/applications/$PKGNAM.desktop
## Are we installing extra cardsets?
if [ -e $CWD/$CARDSETS.tar.bz2 ]; then
- echo -e "Extracting extra cardsets (this may take some time)..."
- ( cd $TMP && tar jxf $CWD/$CARDSETS.tar.bz2 )
- cp -a $TMP/$CARDSETS/* $PKG/usr/share/$PRGNAM/
+ echo -e "Extracting extra cardsets (this may take some time)..."
+ tar xf $CWD/$CARDSETS.tar.bz2 -C $TMP
+ cp -a $TMP/$CARDSETS/* $PKG/usr/share/$PRGNAM/
fi
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
@@ -61,4 +79,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PKGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PKGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/pysolfc/pysolfc.info b/games/pysolfc/pysolfc.info
index a0f036313a..045e7bb246 100644
--- a/games/pysolfc/pysolfc.info
+++ b/games/pysolfc/pysolfc.info
@@ -3,6 +3,8 @@ VERSION="1.1"
HOMEPAGE="http://pysolfc.sourceforge.net"
DOWNLOAD="http://downloads.sourceforge.net/pysolfc/PySolFC-1.1.tar.bz2"
MD5SUM="56aca8101b3534aaf3564c40ed6824f1"
-MAINTAINER="Wade Nelson"
-EMAIL="wade.nels@gmail.com"
-APPROVED="dsomero"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Matthew Fillpot"
+EMAIL="mfilpot@gmail.com"
+APPROVED="rworkman"
diff --git a/games/pysolfc/slack-desc b/games/pysolfc/slack-desc
index c9f875365f..5a4f5c636f 100644
--- a/games/pysolfc/slack-desc
+++ b/games/pysolfc/slack-desc
@@ -7,7 +7,7 @@
|-----handy-ruler------------------------------------------------------|
pysolfc: pysolfc (a solitaire suite)
-pysolfc:
+pysolfc:
pysolfc: PySolFC is a colection of more than 1000 solitaire card games. It is
pysolfc: a fork of the no longer maintained PySol Solitaire. There are games
pysolfc: that use the 52 card International Pattern deck, games for the 78 card
@@ -15,5 +15,5 @@ pysolfc: Tarock deck, eight and ten suite Ganjifa games, Hanafuda games, Matrix
pysolfc: games, Mahjongg games, and games for an original hexadecimal-based
pysolfc: deck. PySolFC features a modern look and feel, multiple cardsets and
pysolfc: backgrounds, sound, unlimited undo, player statistics, and much more.
-pysolfc:
+pysolfc:
pysolfc: PySolFC is distributed under the terms of the GNU GPL.