summaryrefslogtreecommitdiffstats
path: root/gis/OWSLib/OWSLib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/OWSLib/OWSLib.SlackBuild')
-rw-r--r--gis/OWSLib/OWSLib.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/gis/OWSLib/OWSLib.SlackBuild b/gis/OWSLib/OWSLib.SlackBuild
index 0784ae7cbe..2a6acc9a33 100644
--- a/gis/OWSLib/OWSLib.SlackBuild
+++ b/gis/OWSLib/OWSLib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for OWSLib
-# Copyright 2013-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2013-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=OWSLib
-VERSION=${VERSION:-0.17.1}
+VERSION=${VERSION:-0.23.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,10 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true