summaryrefslogtreecommitdiffstats
path: root/gis/cligj
diff options
context:
space:
mode:
Diffstat (limited to 'gis/cligj')
-rw-r--r--gis/cligj/cligj.SlackBuild25
-rw-r--r--gis/cligj/cligj.info6
2 files changed, 19 insertions, 12 deletions
diff --git a/gis/cligj/cligj.SlackBuild b/gis/cligj/cligj.SlackBuild
index a839decb66..95113af96f 100644
--- a/gis/cligj/cligj.SlackBuild
+++ b/gis/cligj/cligj.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# SlackBuild script for cligj
-# Copyright 2015-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2015-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -24,10 +24,13 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=cligj
-VERSION=${VERSION:-0.5.0}
+VERSION=${VERSION:-0.7.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -37,7 +40,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -71,10 +81,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
@@ -86,4 +93,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/gis/cligj/cligj.info b/gis/cligj/cligj.info
index e0b926dbb9..4287ba4f05 100644
--- a/gis/cligj/cligj.info
+++ b/gis/cligj/cligj.info
@@ -1,8 +1,8 @@
PRGNAM="cligj"
-VERSION="0.5.0"
+VERSION="0.7.1"
HOMEPAGE="https://github.com/mapbox/cligj"
-DOWNLOAD="https://github.com/mapbox/cligj/archive/0.5.0/cligj-0.5.0.tar.gz"
-MD5SUM="975f62cec147f68c74be8bc4b70faa14"
+DOWNLOAD="https://github.com/mapbox/cligj/archive/0.7.1/cligj-0.7.1.tar.gz"
+MD5SUM="fe4b6452e96e42254c0e3d4416e19851"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="click"