summaryrefslogtreecommitdiffstats
path: root/gis/gdal/gdal.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/gdal/gdal.SlackBuild')
-rw-r--r--gis/gdal/gdal.SlackBuild24
1 files changed, 5 insertions, 19 deletions
diff --git a/gis/gdal/gdal.SlackBuild b/gis/gdal/gdal.SlackBuild
index 2973ebf43c..89c9e3878b 100644
--- a/gis/gdal/gdal.SlackBuild
+++ b/gis/gdal/gdal.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for GDAL
# Copyright 2009 Marco Cecchetti <mrc.ild@gmail.com>
+# Updated 2019-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
# Maintained by David Spencer <baildon.research@googlemail.com>
PRGNAM=gdal
-VERSION=${VERSION:-2.2.4}
+VERSION=${VERSION:-3.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -130,7 +131,7 @@ CXXFLAGS="$SLKCFLAGS" \
--without-grib \
--with-static-proj4 \
--with-mysql \
- --with-python \
+ --with-python=/usr/bin/python3 \
--with-poppler \
--with-libtiff=internal \
--with-rename-internal-libtiff-symbols=yes \
@@ -143,27 +144,12 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- cd swig/python
- rm -rf build
- python3 setup.py build
- python3 setup.py install --root=$PKG --prefix=/usr
- cd - >/dev/null
-fi
-
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-make -f GNUmakefile -B man
-make install-man DESTDIR=$PKG
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-make -f GNUmakefile -B docs
-# --docdir is ignored :-(
-make install-docs DESTDIR=$PKG INST_DOCS=/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- COMMITERS HOWTO-RELEASE LICENSE.TXT NEWS PROVENANCE.TXT VERSION \
+ COMMITTERS HOWTO-RELEASE LICENSE.TXT NEWS PROVENANCE.TXT VERSION \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild