summaryrefslogtreecommitdiffstats
path: root/gis/gpsbabel/gpsbabel.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/gpsbabel/gpsbabel.SlackBuild')
-rw-r--r--gis/gpsbabel/gpsbabel.SlackBuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/gis/gpsbabel/gpsbabel.SlackBuild b/gis/gpsbabel/gpsbabel.SlackBuild
index 8fe33a62da..3caa41f120 100644
--- a/gis/gpsbabel/gpsbabel.SlackBuild
+++ b/gis/gpsbabel/gpsbabel.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for gpsbabel
-# Copyright 2017 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2017-2019 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=gpsbabel
-VERSION=${VERSION:-1.5.4}
+VERSION=${VERSION:-1.6.0}
SRCVER=${PRGNAM}_$(echo ${VERSION} | tr . _)
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -38,7 +38,7 @@ fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
+PKG=$TMP/package-$PRGNAM-$VERSION
OUTPUT=${OUTPUT:-/tmp}
DOCS="AUTHORS COPYING README*"
@@ -77,23 +77,17 @@ chmod -R u+w,go-w,a+rX-st .
sed -i \
-e '/reportStatistics_/s/true/false/' \
-e '/startupVersionCheck_/s/true/false/' \
- -e '/ignoreVersionMismatch/s/false/true/' \
+ -e '/ignoreVersionMismatch_/s/false/true/' \
gui/babeldata.h
# Make it more FHS-compliant by moving gmapbase.html and the translations
# to /usr/share. Tell the GUI where to find them. Thanks to Arch.
-sed -i 's|QApplication::applicationDirPath() +|"/usr/share/gpsbabel"|' gui/map.cc
-sed -i 's|QApplication::applicationDirPath()|"/usr/share/gpsbabel"|' gui/mainwindow.cc
+sed -i 's|langPath_ = QApplication::applicationDirPath();|langPath_ = "/usr/share/gpsbabel";|' gui/mainwindow.cc
+sed -i 's|baseFile = QApplication::applicationDirPath() + "/gmapbase.html";|baseFile = "/usr/share/gpsbabel/gmapbase.html";|' gui/map.cc
-# Build using the system zlib and libminizip from SBo (see --with-zlib=system).
-# Thanks to Gentoo.
-sed -i '/AC_CHECK_LIB(\[z\], \[gzopen\])/aAC_CHECK_LIB([minizip], [zipOpen64])' configure.in
-sed -i 's|"zlib/contrib/minizip/zip.h"|<minizip/zip.h>|' src/core/ziparchive.cc src/core/ziparchive.h
-
-# Patched to build against Qt5
-patch -p1 < $CWD/build-fix.patch
-
-autoreconf -vif
+# Fix the .desktop file and icon. Thanks to Arch.
+sed -i 's|gpsbabelfe-bin|gpsbabelfe|' gui/gpsbabel.desktop
+convert gui/images/appicon.png +set date:create +set date:modify -background none -gravity center -extent 512x512 gui/images/appicon.png
./configure \
--prefix=/usr \
@@ -112,7 +106,9 @@ make
make gui
install -D -m0755 -s gpsbabel $PKG/usr/bin/gpsbabel
-install -D -m0755 -s gui/objects/gpsbabelfe-bin $PKG/usr/bin/gpsbabelfe
+install -D -m0755 -s gui/objects/gpsbabelfe $PKG/usr/bin/gpsbabelfe
+install -D -m0644 gui/gpsbabel.desktop $PKG/usr/share/applications/gpsbabel.desktop
+install -D -m0644 gui/images/appicon.png $PKG/usr/share/icons/hicolor/512x512/apps/gpsbabel.png
install -D -m0644 gui/gmapbase.html $PKG/usr/share/gpsbabel/gmapbase.html
install -d -m0755 $PKG/usr/share/gpsbabel/translations/
install -D -m0644 gui/*.qm $PKG/usr/share/gpsbabel/translations/
@@ -123,6 +119,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}