summaryrefslogtreecommitdiffstats
path: root/gis/openorienteering-mapper
diff options
context:
space:
mode:
Diffstat (limited to 'gis/openorienteering-mapper')
-rw-r--r--gis/openorienteering-mapper/69977dfd4cbb8608aafa8ca8b5388d4983f5430a.patch35
-rw-r--r--gis/openorienteering-mapper/README5
-rw-r--r--gis/openorienteering-mapper/fix_doc_path.diff11
-rw-r--r--gis/openorienteering-mapper/openorienteering-mapper.SlackBuild22
-rw-r--r--gis/openorienteering-mapper/openorienteering-mapper.info8
5 files changed, 59 insertions, 22 deletions
diff --git a/gis/openorienteering-mapper/69977dfd4cbb8608aafa8ca8b5388d4983f5430a.patch b/gis/openorienteering-mapper/69977dfd4cbb8608aafa8ca8b5388d4983f5430a.patch
new file mode 100644
index 0000000000..6545099e95
--- /dev/null
+++ b/gis/openorienteering-mapper/69977dfd4cbb8608aafa8ca8b5388d4983f5430a.patch
@@ -0,0 +1,35 @@
+From 69977dfd4cbb8608aafa8ca8b5388d4983f5430a Mon Sep 17 00:00:00 2001
+From: Bas Couwenberg <sebastic@debian.org>
+Date: Sat, 23 Oct 2021 17:08:31 +0200
+Subject: [PATCH] Add support for proj.h, proj_api.h is removed in PROJ 8.
+
+---
+ cmake/FindPROJ4.cmake | 15 +++++++++++++++
+ 1 file changed, 15 insertions(+)
+
+diff --git a/cmake/FindPROJ4.cmake b/cmake/FindPROJ4.cmake
+index 093deaa79..10dfc7afa 100644
+--- a/cmake/FindPROJ4.cmake
++++ b/cmake/FindPROJ4.cmake
+@@ -91,6 +91,21 @@ if(PROJ4_INCLUDE_DIR AND EXISTS "${PROJ4_INCLUDE_DIR}/proj_api.h")
+ string(REGEX REPLACE "^.*PJ_VERSION [0-9][0-9]([0-9]).*$" "\\1" PROJ4_VERSION_PATCH "${PROJ4_H}")
+ set(PROJ4_VERSION "${PROJ4_VERSION_MAJOR}.${PROJ4_VERSION_MINOR}.${PROJ4_VERSION_PATCH}")
+ set(PROJ4_VERSION_COUNT 3)
++else()
++ find_path(PROJ4_INCLUDE_DIR NAMES proj.h ${_PROJ4_SEARCH} PATH_SUFFIXES include)
++ mark_as_advanced(PROJ4_INCLUDE_DIR)
++
++ if(PROJ4_INCLUDE_DIR AND EXISTS "${PROJ4_INCLUDE_DIR}/proj.h")
++ file(STRINGS "${PROJ4_INCLUDE_DIR}/proj.h" PROJ_VERSION_MAJOR REGEX "^#define PROJ_VERSION_MAJOR [0-9]+$")
++ file(STRINGS "${PROJ4_INCLUDE_DIR}/proj.h" PROJ_VERSION_MINOR REGEX "^#define PROJ_VERSION_MINOR [0-9]+$")
++ file(STRINGS "${PROJ4_INCLUDE_DIR}/proj.h" PROJ_VERSION_PATCH REGEX "^#define PROJ_VERSION_PATCH [0-9]+$")
++
++ string(REGEX REPLACE "^.*PROJ_VERSION_[A-Z]+ ([0-9]).*$" "\\1" PROJ4_VERSION_MAJOR "${PROJ_VERSION_MAJOR}")
++ string(REGEX REPLACE "^.*PROJ_VERSION_[A-Z]+ ([0-9]).*$" "\\1" PROJ4_VERSION_MINOR "${PROJ_VERSION_MINOR}")
++ string(REGEX REPLACE "^.*PROJ_VERSION_[A-Z]+ ([0-9]).*$" "\\1" PROJ4_VERSION_PATCH "${PROJ_VERSION_PATCH}")
++ set(PROJ4_VERSION "${PROJ4_VERSION_MAJOR}.${PROJ4_VERSION_MINOR}.${PROJ4_VERSION_PATCH}")
++ set(PROJ4_VERSION_COUNT 3)
++ endif()
+ endif()
+
+ # Allow PROJ4_LIBRARY to be set manually, as the location of the proj library
diff --git a/gis/openorienteering-mapper/README b/gis/openorienteering-mapper/README
index 8dafcbf0d5..316c8a5b7f 100644
--- a/gis/openorienteering-mapper/README
+++ b/gis/openorienteering-mapper/README
@@ -1,2 +1,3 @@
-OpenOrienteering Mapper is an orienteering mapmaking program and provides
-a free and open source alternative to existing commercial software.
+OpenOrienteering Mapper is an orienteering mapmaking program and
+provides a free and open source alternative to existing commercial
+software.
diff --git a/gis/openorienteering-mapper/fix_doc_path.diff b/gis/openorienteering-mapper/fix_doc_path.diff
deleted file mode 100644
index 87b1586cf0..0000000000
--- a/gis/openorienteering-mapper/fix_doc_path.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- mapper-0.9.0/CMakeLists.txt.orig 2019-10-24 00:33:05.001359242 +0300
-+++ mapper-0.9.0/CMakeLists.txt 2019-10-24 00:33:50.964840135 +0300
-@@ -133,7 +133,7 @@
- set(MAPPER_RUNTIME_DESTINATION "bin")
- set(MAPPER_LIBRARY_DESTINATION "lib/${Mapper_PACKAGE_NAME}")
- set(MAPPER_DATA_DESTINATION "share/${Mapper_PACKAGE_NAME}")
-- set(MAPPER_ABOUT_DESTINATION "share/doc/${Mapper_PACKAGE_NAME}")
-+ set(MAPPER_ABOUT_DESTINATION "doc/${Mapper_PACKAGE_NAME}-${Mapper_VERSION}")
- endif()
-
- if(CMAKE_CROSSCOMPILING)
diff --git a/gis/openorienteering-mapper/openorienteering-mapper.SlackBuild b/gis/openorienteering-mapper/openorienteering-mapper.SlackBuild
index 752d1ef2b4..ed77cca493 100644
--- a/gis/openorienteering-mapper/openorienteering-mapper.SlackBuild
+++ b/gis/openorienteering-mapper/openorienteering-mapper.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for OpenOrienteering Mapper
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=openorienteering-mapper
-VERSION=${VERSION:-0.9.0}
+VERSION=${VERSION:-0.9.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,7 +79,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/fix_doc_path.diff
+# patch for Proj 8 submitted PR to upstream from debian
+patch -p1 < $CWD/69977dfd4cbb8608aafa8ca8b5388d4983f5430a.patch
mkdir -p build
cd build
@@ -78,6 +89,7 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_DOCDIR="/usr/doc/$PRGNAM-$VERSION" \
-DLICENSING_PROVIDER:BOOL=OFF \
-DMapper_PACKAGE_NAME=$PRGNAM \
-Wno-dev ..
@@ -99,4 +111,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/gis/openorienteering-mapper/openorienteering-mapper.info b/gis/openorienteering-mapper/openorienteering-mapper.info
index 9df71846be..b7e51274b6 100644
--- a/gis/openorienteering-mapper/openorienteering-mapper.info
+++ b/gis/openorienteering-mapper/openorienteering-mapper.info
@@ -1,10 +1,10 @@
PRGNAM="openorienteering-mapper"
-VERSION="0.9.0"
+VERSION="0.9.5"
HOMEPAGE="https://www.openorienteering.org/apps/mapper/"
-DOWNLOAD="https://github.com/OpenOrienteering/mapper/archive/v0.9.0/mapper-0.9.0.tar.gz"
-MD5SUM="7135d60bcacaba0fde002543705c9eea"
+DOWNLOAD="https://github.com/OpenOrienteering/mapper/archive/v0.9.5/mapper-0.9.5.tar.gz"
+MD5SUM="87cde1b4bbb94704ec1dc356674ec92d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="gdal polyclipping proj qt5"
+REQUIRES="gdal polyclipping"
MAINTAINER="Nikolay Korotkiy"
EMAIL="sikmir@gmail.com"