summaryrefslogtreecommitdiffstats
path: root/gis/pyshp
diff options
context:
space:
mode:
Diffstat (limited to 'gis/pyshp')
-rw-r--r--gis/pyshp/pyshp.SlackBuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/gis/pyshp/pyshp.SlackBuild b/gis/pyshp/pyshp.SlackBuild
index e30ce95797..4b4b2ff3c9 100644
--- a/gis/pyshp/pyshp.SlackBuild
+++ b/gis/pyshp/pyshp.SlackBuild
@@ -67,15 +67,20 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a changelog.txt README.md LICENSE.TXT $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ changelog.txt README.md LICENSE.TXT \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install