summaryrefslogtreecommitdiffstats
path: root/gis/python3-cartopy/python3-cartopy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/python3-cartopy/python3-cartopy.SlackBuild')
-rw-r--r--gis/python3-cartopy/python3-cartopy.SlackBuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/gis/python3-cartopy/python3-cartopy.SlackBuild b/gis/python3-cartopy/python3-cartopy.SlackBuild
index eb86fe6917..42993d5796 100644
--- a/gis/python3-cartopy/python3-cartopy.SlackBuild
+++ b/gis/python3-cartopy/python3-cartopy.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python3-cartopy
# Copyright 2014-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2021-2022 Gregory J. L. Tourte <artourter@gmail.com>
+# Copyright 2021-2023 Gregory J. L. Tourte <artourter@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-cartopy
-VERSION=${VERSION:-0.20.3}
+VERSION=${VERSION:-0.22.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -77,12 +77,20 @@ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -perm /111 -o \! -perm 755 -o -exec chmod 755 {} + -o \
+ \! -perm /111 -o \! -perm 644 -o -exec chmod 644 {} +
-python3 setup.py install --root=$PKG
+# Fixing numpy dependency check in pyproject.toml:
+# oldest-supported-numpy has a strict check and doesn't support newer version
+# so we replace it. The alternative is to add --skip-dependency-check to tbe
+# build line but this is not deemed optimal.
+sed -i 's/oldest-supported-numpy/numpy>=1.19.3/' pyproject.toml
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true