summaryrefslogtreecommitdiffstats
path: root/gis/python3-pyproj/python3-pyproj.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/python3-pyproj/python3-pyproj.SlackBuild')
-rw-r--r--gis/python3-pyproj/python3-pyproj.SlackBuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/gis/python3-pyproj/python3-pyproj.SlackBuild b/gis/python3-pyproj/python3-pyproj.SlackBuild
index ce41b4e55b..55256a46f3 100644
--- a/gis/python3-pyproj/python3-pyproj.SlackBuild
+++ b/gis/python3-pyproj/python3-pyproj.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for pyproj
# Copyright 2013-2021 Benjamin Trigona-Harany
-# Copyright 2021-2022 Gregory J. L. Tourte <artourter@gmail.com>
+# Copyright 2021-2023 Gregory J. L. Tourte <artourter@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pyproj
-VERSION=${VERSION:-3.3.1}
+VERSION=${VERSION:-3.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,7 +82,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true