summaryrefslogtreecommitdiffstats
path: root/gis/pytrainer/pytrainer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/pytrainer/pytrainer.SlackBuild')
-rw-r--r--gis/pytrainer/pytrainer.SlackBuild31
1 files changed, 8 insertions, 23 deletions
diff --git a/gis/pytrainer/pytrainer.SlackBuild b/gis/pytrainer/pytrainer.SlackBuild
index 0c6b2c5e3e..bb828e8217 100644
--- a/gis/pytrainer/pytrainer.SlackBuild
+++ b/gis/pytrainer/pytrainer.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Pytrainer
-# Copyright 2014 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2014-2017 Kyle Guinn <elyk03@gmail.com>, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,12 +24,12 @@
PRGNAM=pytrainer
VERSION=${VERSION:-1.10.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$(uname -m) ;;
esac
@@ -42,34 +42,19 @@ OUTPUT=${OUTPUT:-/tmp}
DOCS="CHANGES COPYING INSTALL PLUGINS.README README.md"
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/v$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+chmod -R u+w,go-w,a+rX-st .
+
+# Apply select commits from upstream.
+patch -p1 < $CWD/patches/fcc8f3361d4ff25559cb87a375fbbfc1192ca334.diff
python setup.py install --root=$PKG