summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
Diffstat (limited to 'gis')
-rw-r--r--gis/basemap/README2
-rw-r--r--gis/basemap/basemap.SlackBuild86
-rw-r--r--gis/basemap/basemap.info10
-rw-r--r--gis/basemap/slack-desc19
4 files changed, 0 insertions, 117 deletions
diff --git a/gis/basemap/README b/gis/basemap/README
deleted file mode 100644
index 1f96d1c8ac..0000000000
--- a/gis/basemap/README
+++ /dev/null
@@ -1,2 +0,0 @@
-Plot on map projections (with coastlines and political boundaries)
-using matplotlib.
diff --git a/gis/basemap/basemap.SlackBuild b/gis/basemap/basemap.SlackBuild
deleted file mode 100644
index b61a4f4cc1..0000000000
--- a/gis/basemap/basemap.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for basemap
-
-# Originally written by Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-# Copyright (c) 2019 Cristiano Urban, Gonars, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=basemap
-VERSION=${VERSION:-1.2.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-${VERSION}rel
-tar xvf $CWD/$PRGNAM-${VERSION}rel.tar.gz
-cd $PRGNAM-${VERSION}rel
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE* README.md Changelog $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/basemap/basemap.info b/gis/basemap/basemap.info
deleted file mode 100644
index f0db4505a0..0000000000
--- a/gis/basemap/basemap.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="basemap"
-VERSION="1.2.1"
-HOMEPAGE="https://github.com/matplotlib/basemap/"
-DOWNLOAD="https://github.com/matplotlib/basemap/archive/v1.2.1rel/basemap-1.2.1rel.tar.gz"
-MD5SUM="b3c4c1292b36abac27050eb67ada914e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="geos matplotlib pyproj pyshp"
-MAINTAINER="Cristiano Urban"
-EMAIL="cristiano.urban.slack@gmail.com"
diff --git a/gis/basemap/slack-desc b/gis/basemap/slack-desc
deleted file mode 100644
index ef632ef9de..0000000000
--- a/gis/basemap/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-basemap: basemap (matplotlib library)
-basemap:
-basemap: Plot on map projections (with coastlines and political boundaries)
-basemap: using matplotlib.
-basemap:
-basemap: Homepage: https://github.com/matplotlib/basemap/
-basemap:
-basemap:
-basemap:
-basemap:
-basemap: