summaryrefslogtreecommitdiffstats
path: root/graphics/frescobaldi/frescobaldi.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/frescobaldi/frescobaldi.SlackBuild')
-rw-r--r--graphics/frescobaldi/frescobaldi.SlackBuild24
1 files changed, 19 insertions, 5 deletions
diff --git a/graphics/frescobaldi/frescobaldi.SlackBuild b/graphics/frescobaldi/frescobaldi.SlackBuild
index 62c49cc3ac..fdee3a0c8d 100644
--- a/graphics/frescobaldi/frescobaldi.SlackBuild
+++ b/graphics/frescobaldi/frescobaldi.SlackBuild
@@ -1,12 +1,15 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for <frescobaldi>
# Written by Michales Michaloudes korgie@gmail.com
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=frescobaldi
-VERSION=${VERSION:-2.20.0}
+VERSION=${VERSION:-3.1.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -16,7 +19,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -50,8 +60,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Provided by hyphen-*
+rm -f frescobaldi_app/hyphdicts/hyph_*.dic
+rm -f frescobaldi_app/hyphdicts/README*
+
mkdir -p $PKG/usr/bin
-python setup.py install --root $PKG
+python3 setup.py install --root $PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -74,4 +88,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE