summaryrefslogtreecommitdiffstats
path: root/graphics/hp2xx
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/hp2xx')
-rw-r--r--graphics/hp2xx/README14
-rw-r--r--graphics/hp2xx/hp2xx.SlackBuild10
2 files changed, 9 insertions, 15 deletions
diff --git a/graphics/hp2xx/README b/graphics/hp2xx/README
index 174bbf3b63..7f85bbd8cd 100644
--- a/graphics/hp2xx/README
+++ b/graphics/hp2xx/README
@@ -1,14 +1,14 @@
hp2xx (vector graphics conversion)
-The hp2xx program is a versatile tool to convert vector-oriented graphics
-data given in Hewlett-Packard's HP-GL plotter language into a variety
-of popular graphics formats, both vector- and raster-oriented.
+The hp2xx program is a versatile tool to convert vector-oriented
+graphics data given in Hewlett-Packard's HP-GL plotter language into a
+variety of popular graphics formats, both vector- and raster-oriented.
The various supported output formats include Encapsulated PostScript
-(EPS), PCX, IMG, and several formats intended to facilitate the generation
-of graphics within TeX documents. In addition, hp2xx output is printable
-on the HP Laserjet/Deskjet printer series, and it may be used as a HP-GL
-previewer on many platforms.
+(EPS), PCX, IMG, and several formats intended to facilitate the
+generation of graphics within TeX documents. In addition, hp2xx output
+is printable on the HP Laserjet/Deskjet printer series, and it may be
+used as a HP-GL previewer on many platforms.
It can be used as an ImageMagick or GraphicsMagick delegate to convert
from HPGL format.
diff --git a/graphics/hp2xx/hp2xx.SlackBuild b/graphics/hp2xx/hp2xx.SlackBuild
index ebf6fed3f9..3f656af52b 100644
--- a/graphics/hp2xx/hp2xx.SlackBuild
+++ b/graphics/hp2xx/hp2xx.SlackBuild
@@ -22,9 +22,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -58,11 +55,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
sed -i "s,-O2 -g,$SLKCFLAGS," sources/Makefile