summaryrefslogtreecommitdiffstats
path: root/graphics/k3d/k3d.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/k3d/k3d.SlackBuild')
-rw-r--r--graphics/k3d/k3d.SlackBuild30
1 files changed, 26 insertions, 4 deletions
diff --git a/graphics/k3d/k3d.SlackBuild b/graphics/k3d/k3d.SlackBuild
index eccafb932f..1f85c0ab14 100644
--- a/graphics/k3d/k3d.SlackBuild
+++ b/graphics/k3d/k3d.SlackBuild
@@ -3,13 +3,32 @@
# Slackware build script for k3d
# 3D modeling and animation software
-# Written by Niels Horn <niels.horn@gmail.com>
-# (based on a script by Larry Hajali)
-# Revision date: 2011/05/01
+# Copyright 2010 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2010-2012 Niels Horn, Rio de Janeiro, RJ, Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Revision date: 2012/09/14
PRGNAM=k3d
VERSION=${VERSION:-0.8.0.2}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -60,6 +79,9 @@ patch -p1 < $CWD/png14.patch
# Patch code for gtkmm-2.24
patch -p1 < $CWD/k3d_gtkmm224.patch
+# Patch to build against gcc-4.7
+patch -p1 < $CWD/k3d_gcc47.patch
+
# Fix man install directory.
sed -i "s|share/man|man|" man/CMakeLists.txt