summaryrefslogtreecommitdiffstats
path: root/graphics/tclblt/patches/05-tk8.5-zoomstack.patch
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/tclblt/patches/05-tk8.5-zoomstack.patch')
-rw-r--r--graphics/tclblt/patches/05-tk8.5-zoomstack.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/graphics/tclblt/patches/05-tk8.5-zoomstack.patch b/graphics/tclblt/patches/05-tk8.5-zoomstack.patch
new file mode 100644
index 0000000000..268e154cda
--- /dev/null
+++ b/graphics/tclblt/patches/05-tk8.5-zoomstack.patch
@@ -0,0 +1,38 @@
+ * Apply 3 changes based on revisions developed by the fedora linux team.
+ + 03-fedora-patch-2.diff
+ + 04-fedora-tk8.5.6.patch.diff
+ --> + 05-tk8.5-zoomstack.diff
+ * Those patches are required to solve segmentation faults that are observed
+ when blt is used with tcltk 8.5. We have a substantial amount of
+ experience using this patched version of blt in the Swarm
+ Simulation System (www.swarm.org) and have observed no ill-effects.
+Author: Paul E. Johnson (Debian Packaging) <pauljohn32@freefaculty.org>
+
+--- a/library/Makefile.in
++++ b/library/Makefile.in
+@@ -29,6 +29,7 @@
+ tabnotebook.tcl \
+ tabset.tcl \
+ treeview.tcl \
++ ZoomStack.itcl \
+ tvutil.tcl \
+ init.tcl \
+ tclIndex \
+--- a/library/ZoomStack.itcl
++++ b/library/ZoomStack.itcl
+@@ -1,4 +1,6 @@
+-import add itcl
++#import add itcl
++package require Itcl
++namespace import itcl::*
+
+ class ZoomStackGraph {
+
+@@ -48,6 +50,7 @@
+ private method SaveCoords { x y }
+ private method Zoom {}
+ private method Unzoom {}
++ private method Empty {}
+ private method Push { cmd }
+ private method Pop {}
+ private method MarkPoint { x y }