summaryrefslogtreecommitdiffstats
path: root/ham/direwolf/direwolf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'ham/direwolf/direwolf.SlackBuild')
-rw-r--r--ham/direwolf/direwolf.SlackBuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/ham/direwolf/direwolf.SlackBuild b/ham/direwolf/direwolf.SlackBuild
index 83226d1803..e9f0bbe1ae 100644
--- a/ham/direwolf/direwolf.SlackBuild
+++ b/ham/direwolf/direwolf.SlackBuild
@@ -21,7 +21,7 @@
# that is unlikely, as I am rather tall.
PRGNAM=direwolf
-VERSION=${VERSION:-1.1}
+VERSION=${VERSION:-1.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -68,7 +68,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix some silly Makefile choices
-todos < $CWD/Makefile.patch | patch -p0 --binary
+patch -p0 < $CWD/Makefile.patch
CFLAGS="$SLKCFLAGS -DUSE_ALSA -pthread -Iutm" \
LDFLAGS="-L/lib${LIBDIRSUFFIX} -L/usr/lib${LIBDIRSUFFIX}" \
@@ -78,16 +78,10 @@ INSTALL=install \
docdir=/usr/doc/$PRGNAM-$VERSION \
sysconfdir=/etc \
LINK_IN_HOME=no \
-make -f Makefile.linux install install-conf DESTDIR=$PKG
+make -f Makefile.linux install DESTDIR=$PKG/usr
-# direwolf comes with a lovely desktop
-# file that assumes LXDE. Use our own
-# here.
-install -m 644 $CWD/direwolf.desktop $PKG/usr/share/applications/
mkdir -p $PKG/usr/share/pixmaps
-cp -a $PKG/usr/share/direwolf/dw-icon.png $PKG/usr/share/pixmaps/
-
-mv $PKG/etc/direwolf.conf $PKG/etc/direwolf.conf.new
+cp -a $PKG/usr/share/direwolf/pixmaps/dw-icon.png $PKG/usr/share/pixmaps/
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true