summaryrefslogtreecommitdiffstats
path: root/libraries/Impacket/Impacket.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/Impacket/Impacket.SlackBuild')
-rw-r--r--libraries/Impacket/Impacket.SlackBuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/libraries/Impacket/Impacket.SlackBuild b/libraries/Impacket/Impacket.SlackBuild
index 1d22002ffa..3f5ab040fb 100644
--- a/libraries/Impacket/Impacket.SlackBuild
+++ b/libraries/Impacket/Impacket.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for Impacket.
# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
-# Copyright 2015-2016, 2018 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2015-2020, Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,7 @@
PRGNAM=Impacket
SRCNAM=impacket
-SRCVER=_0_9_17
-VERSION=${VERSION:-0.9.17}
+VERSION=${VERSION:-0.9.21}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,9 +63,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$SRCNAM$SRCVER
-tar -xzvf $CWD/$SRCNAM-$SRCNAM$SRCVER.tar.gz
-cd $SRCNAM-$SRCNAM$SRCVER
+rm -rf $SRCNAM-$VERSION
+tar -xzvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -74,6 +73,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Python3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \