summaryrefslogtreecommitdiffstats
path: root/libraries/PyYAML/PyYAML.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/PyYAML/PyYAML.SlackBuild')
-rw-r--r--libraries/PyYAML/PyYAML.SlackBuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/libraries/PyYAML/PyYAML.SlackBuild b/libraries/PyYAML/PyYAML.SlackBuild
index 049f16169d..c329f84960 100644
--- a/libraries/PyYAML/PyYAML.SlackBuild
+++ b/libraries/PyYAML/PyYAML.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Slackware build script for PyYAML
-# Copyright 2010 David Woodfall <dave@dawoodfall.net>
+# Copyright 2010-2019 David Woodfall <dave@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,8 +22,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=PyYAML
-VERSION=${VERSION:-3.11}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.13}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -63,14 +63,14 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION