summaryrefslogtreecommitdiffstats
path: root/libraries/aqbanking/aqbanking.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/aqbanking/aqbanking.SlackBuild')
-rw-r--r--libraries/aqbanking/aqbanking.SlackBuild35
1 files changed, 27 insertions, 8 deletions
diff --git a/libraries/aqbanking/aqbanking.SlackBuild b/libraries/aqbanking/aqbanking.SlackBuild
index 09967b2b5a..f5d258db0f 100644
--- a/libraries/aqbanking/aqbanking.SlackBuild
+++ b/libraries/aqbanking/aqbanking.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for aqbanking
-# Copyright 2013-2020 Heiko Rosemann Germany
+# Copyright 2013-2023 Heiko Rosemann Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,18 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220407 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - get rid of compiled tutorials from doc dir.
+# - remove useless INSTALL from doc dir.
+# - remove /usr/share/doc.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=aqbanking
-VERSION=${VERSION:-6.0.2}
+VERSION=${VERSION:-6.5.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +43,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -66,9 +78,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -88,7 +100,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README TODO tutorials doc \
+cp -a AUTHORS COPYING ChangeLog NEWS README TODO tutorials doc \
$PKG/usr/doc/$PRGNAM-$VERSION
# Remove Makefiles from documentation directories
rm $PKG/usr/doc/$PRGNAM-$VERSION/doc/01-OVERVIEW
@@ -96,10 +108,17 @@ rm $PKG/usr/doc/$PRGNAM-$VERSION/doc/Makefile*
rm $PKG/usr/doc/$PRGNAM-$VERSION/doc/apidoc.h
rm $PKG/usr/doc/$PRGNAM-$VERSION/tutorials/Makefile*
+rm -rf $PKG/usr/doc/$PRGNAM-$VERSION/tutorials/.libs # 20220407 bkw: no.
+rm -rf $PKG/usr/share/doc
+
+# Don't ship .la files:
+rm -f $PKG/usr/lib${LIBDIRSUFFIX}/*.la
+rm -f $PKG/usr/lib${LIBDIRSUFFIX}/${PRGNAM}/plugins/44/dbio/*.la
+
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE