summaryrefslogtreecommitdiffstats
path: root/libraries/botocore/botocore.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/botocore/botocore.SlackBuild')
-rw-r--r--libraries/botocore/botocore.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/libraries/botocore/botocore.SlackBuild b/libraries/botocore/botocore.SlackBuild
index a0affe3200..64d2b01477 100644
--- a/libraries/botocore/botocore.SlackBuild
+++ b/libraries/botocore/botocore.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for botocore
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2020 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=botocore
-VERSION=${VERSION:-1.12.57}
+VERSION=${VERSION:-1.18.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true