summaryrefslogtreecommitdiffstats
path: root/libraries/dropbox-python/dropbox-python.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/dropbox-python/dropbox-python.SlackBuild')
-rw-r--r--libraries/dropbox-python/dropbox-python.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/libraries/dropbox-python/dropbox-python.SlackBuild b/libraries/dropbox-python/dropbox-python.SlackBuild
index 9afd173e09..11f45dab81 100644
--- a/libraries/dropbox-python/dropbox-python.SlackBuild
+++ b/libraries/dropbox-python/dropbox-python.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for dropbox-python
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=dropbox-python
SCRNAM=$(printf $PRGNAM | cut -c1-7)
-VERSION=${VERSION:-8.7.1}
+VERSION=${VERSION:-9.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,6 +72,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true