summaryrefslogtreecommitdiffstats
path: root/libraries/girara/girara.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/girara/girara.SlackBuild')
-rw-r--r--libraries/girara/girara.SlackBuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/libraries/girara/girara.SlackBuild b/libraries/girara/girara.SlackBuild
index 49ea5ea3dc..a422527a3c 100644
--- a/libraries/girara/girara.SlackBuild
+++ b/libraries/girara/girara.SlackBuild
@@ -2,19 +2,22 @@
# Slackware build script for girara
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20240319 bkw: update for v0.4.2 (*not* 0.4.3, it needs a newer pango).
+# 20230105 bkw: update for v0.3.8.
+# 20221114 bkw: update for v0.3.7.
+# 20211225 bkw: update for v0.3.6.
# 20180903 bkw: Fix build with Russian (and possibly other non-English) locale.
-
# 20180619 bkw: Update for v0.3.0. Upstream switched from make to meson,
# so this script's no longer compatible with older versions of girara.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=girara
-VERSION=${VERSION:-0.3.0}
+VERSION=${VERSION:-0.4.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -27,9 +30,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -65,6 +65,10 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+# 20240319 bkw: upstream decided we needed a newer meson, but this
+# builds just fine with our older one.
+sed -i '/meson_version/s,>=0\.61,>=0.59,' meson.build
+
# Something in the ninja/meson build stuff is grepping the output of
# some command, looking for a specific string in English. Building with
# e.g. ru_RU.UTF-8 locale breaks it. Meson and ninja are totally new to
@@ -97,7 +101,7 @@ DESTDIR="$PKG" "${NINJA:=ninja}" -C build install
strip $PKG/usr/lib$LIBDIRSUFFIX/*.so.*.*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS* LICENSE* README* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install