summaryrefslogtreecommitdiffstats
path: root/libraries/lablgtk/lablgtk.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/lablgtk/lablgtk.SlackBuild')
-rw-r--r--libraries/lablgtk/lablgtk.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/libraries/lablgtk/lablgtk.SlackBuild b/libraries/lablgtk/lablgtk.SlackBuild
index 5014f49edd..3709452287 100644
--- a/libraries/lablgtk/lablgtk.SlackBuild
+++ b/libraries/lablgtk/lablgtk.SlackBuild
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=lablgtk
-VERSION=${VERSION:-2.18.0}
+VERSION=${VERSION:-2.18.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -81,6 +81,9 @@ sed -i -e "s/\\(CFLAGS += -O\\)/CFLAGS +=/" src/Makefile
make -j1 world
make DESTDIR=$PKG install
+# remove file conflicting with ocaml's ones
+rm -f $PKG/usr/lib$LIBDIRSUFFIX/ocaml/ld.conf
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true