summaryrefslogtreecommitdiffstats
path: root/libraries/libpaper/libpaper.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libpaper/libpaper.SlackBuild')
-rw-r--r--libraries/libpaper/libpaper.SlackBuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/libraries/libpaper/libpaper.SlackBuild b/libraries/libpaper/libpaper.SlackBuild
index dade199995..75de6b67d3 100644
--- a/libraries/libpaper/libpaper.SlackBuild
+++ b/libraries/libpaper/libpaper.SlackBuild
@@ -3,16 +3,17 @@
# Slackware build script for libpaper
# Written by Pablo Santamaria (pablosantamaria@gmail.com)
+# Note: history shows first and last three version changes.
# Update by Tim Dickson (dickson.tim@googlemail.com) for 1.1.24+nmu4 version
-# 26/06/2017 updated by Tim Dickson for 1.1.24+nmu5 version
-# 10/02/2019 updated for 1.1.26
-# 25/06/2019 updated for 1.1.27
-# 25/06/2019 updated for 1.1.28
+# 16/10/2023 updated for 2.1.2
+# 31/01/2024 updated to 2.1.3 tidy up this history to show just first and last 3 changes
+# 14/03/2024 updated to 2.2.5
+# note: we use release source, as archive source misses out submodules.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=libpaper
-VERSION=${VERSION:-1.1.28}
+VERSION=${VERSION:-2.2.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -51,7 +52,8 @@ else
LIBDIRSUFFIX=""
fi
-# Set default papersize: a3, a4, a5, b5, letter, legal, executive, note, 11x17
+# Set default papersize: a3, a4, a5, b5, letter, legal, executive, note, 11x17 etc..
+# /etc/paperspecs contains the full list.
PAPERSIZE=${PAPERSIZE:-a4}
set -e
@@ -60,7 +62,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf "$CWD/${PRGNAM}_${VERSION}.tar.gz"
+tar xvf "$CWD/${PRGNAM}-${VERSION}.tar.gz"
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -68,12 +70,13 @@ find -L . \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-#patch configure.ac for default paper size
-sed -i "s/PAPERSIZE=letter/PAPERSIZE=$PAPERSIZE/g" configure.ac
-autoreconf -i
+#patch configure.ac to allow with slackware's autoconf version
+sed -i "s/2.71/2.69/g" configure.ac
+#autoreconf -i -f
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
+ --enable-relocatable \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
@@ -84,7 +87,7 @@ CXXFLAGS="$SLKCFLAGS" \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
-
+rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
# Create a /etc/papersize default file
mkdir -p $PKG/etc
echo $PAPERSIZE > $PKG/etc/papersize.new
@@ -98,7 +101,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README COPYING ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md COPYING COPYING-GPL-3 $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install