summaryrefslogtreecommitdiffstats
path: root/libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.SlackBuild')
-rw-r--r--libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.SlackBuild119
1 files changed, 119 insertions, 0 deletions
diff --git a/libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.SlackBuild b/libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.SlackBuild
new file mode 100644
index 0000000000..5c72ee2bc7
--- /dev/null
+++ b/libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.SlackBuild
@@ -0,0 +1,119 @@
+#!/bin/sh
+
+# Slackware build script for libtorrent (rasterbar)
+
+# Copyright 2019-2020 Donald Cooley, South Haven, Indiana USA
+# Copyright 2009-2015 Erik W. Hanson, Minneapolis, MN, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libtorrent-rasterbar-legacy
+SRCNAM=libtorrent-rasterbar
+VERSION=${VERSION:-1.1.14}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i586 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# https://github.com/qbittorrent/qBittorrent/issues/6383#issuecomment-281535787
+sed -i -e "s/+ target_specific(),/+ target_specific() + ['-std=c++11'],/" \
+ bindings/python/setup.py
+
+EXAMPLES=${EXAMPLES:-no}
+[ "$EXAMPLES" = "yes" ] && examples="--enable-examples"
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS -std=c++11" \
+LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --disable-static \
+ --enable-python-binding \
+ --enable-encryption \
+ $examples \
+ --with-boost-libdir=/usr/lib${LIBDIRSUFFIX} \
+ --disable-debug \
+ --build=$ARCH-slackware-linux
+
+make
+make install-strip DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog NEWS docs/ tools/ \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+
+if [ "$EXAMPLES" = "yes" ]; then
+ cp -a examples/ $PKG/usr/doc/$PRGNAM-$VERSION
+ cp -a ed25519/ $PKG/usr/doc/$PRGNAM-$VERSION
+fi
+
+find $PKG \
+ \( -name .deps -o -name .libs -o -name .dirstamp \
+ \) -exec rm -rf {} \; || true
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}