summaryrefslogtreecommitdiffstats
path: root/libraries/libwhisker2/libwhisker2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libwhisker2/libwhisker2.SlackBuild')
-rw-r--r--libraries/libwhisker2/libwhisker2.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/libraries/libwhisker2/libwhisker2.SlackBuild b/libraries/libwhisker2/libwhisker2.SlackBuild
index 5f75665022..be2e8c1b8a 100644
--- a/libraries/libwhisker2/libwhisker2.SlackBuild
+++ b/libraries/libwhisker2/libwhisker2.SlackBuild
@@ -70,8 +70,8 @@ cd $PRGNAM-$VERSION
cat $CWD/Makefiles.patch | patch -p1
chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
@@ -90,7 +90,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
)
( cd $PKG
- find . \( -name "perllocal.pod" -o -name ".packlist" -o -name "*.bs" \) \
+ find -L . \( -name "perllocal.pod" -o -name ".packlist" -o -name "*.bs" \) \
-exec rm -f {} \;
)