summaryrefslogtreecommitdiffstats
path: root/libraries/podofo/podofo.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/podofo/podofo.SlackBuild')
-rw-r--r--libraries/podofo/podofo.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/libraries/podofo/podofo.SlackBuild b/libraries/podofo/podofo.SlackBuild
index 926b5372d3..fcc3723ad3 100644
--- a/libraries/podofo/podofo.SlackBuild
+++ b/libraries/podofo/podofo.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for podofo
-# Copyright 2009-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2020 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=podofo
-VERSION=${VERSION:-0.9.5}
+VERSION=${VERSION:-0.9.6}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
@@ -71,8 +71,8 @@ find -L . \
# Fix mandir directory.
sed -i 's|share/man|man|' CMakeLists.txt
-# Fix building podofo on x86 with cppunit.
-patch -p1 < $CWD/podofo-0.9.4_build.patch
+# Ref: https://sourceforge.net/p/podofo/tickets/28/
+patch -p1 < $CWD/XRefStrParObj-deprecated.patch
mkdir build
cd build
@@ -92,7 +92,7 @@ cd build
make install DESTDIR=$PKG
cd -
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;