summaryrefslogtreecommitdiffstats
path: root/libraries/pylast/pylast.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/pylast/pylast.SlackBuild')
-rw-r--r--libraries/pylast/pylast.SlackBuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/libraries/pylast/pylast.SlackBuild b/libraries/pylast/pylast.SlackBuild
index 3c333b28e1..bb11809871 100644
--- a/libraries/pylast/pylast.SlackBuild
+++ b/libraries/pylast/pylast.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pylast
-# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2021 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pylast
-VERSION=${VERSION:-2.4.0} # This is the last verion that is compatible
-BUILD=${BUILD:-1} # with Python 2
+VERSION=${VERSION:-4.1.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -54,9 +54,6 @@ else
LIBDIRSUFFIX=""
fi
-PYTHON=python
-[ "${PYTHON3:-no}" = "yes" ] && PYTHON=python3
-
set -e
rm -rf $PKG
@@ -72,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-$PYTHON setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true