summaryrefslogtreecommitdiffstats
path: root/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild')
-rw-r--r--libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild b/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
index 17b1b8ee01..9eb2692772 100644
--- a/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
+++ b/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-ruamel.yaml
-# Copyright 2019, Alexander Verbovetsky, Moscow, Russia
+# Copyright 2019-2021, Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-ruamel.yaml
VERSION=${VERSION:-0.16.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -58,6 +58,10 @@ find -L . \
RUAMEL_NO_PIP_INSTALL_CHECK=1 python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ RUAMEL_NO_PIP_INSTALL_CHECK=1 python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true