summaryrefslogtreecommitdiffstats
path: root/libraries/stfl/python-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/stfl/python-support.patch')
-rw-r--r--libraries/stfl/python-support.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/libraries/stfl/python-support.patch b/libraries/stfl/python-support.patch
index 514d93af25..b11c7be0bf 100644
--- a/libraries/stfl/python-support.patch
+++ b/libraries/stfl/python-support.patch
@@ -82,7 +82,7 @@ diff -Nur stfl-0.24/python3/Makefile.snippet stfl-0.24-py3/python3/Makefile.snip
- cp python/stfl.py $(DESTDIR)$(PYTHON_SITEARCH)/
+python3/_stfl.so python3/stfl.py python3/stfl.pyc: libstfl.a stfl.h python3/stfl.i swig/*.i
+ cd python3 && swig -python -threads stfl.i
-+ gcc -shared -pthread -fPIC python3/stfl_wrap.c -I/usr/include/python$(PYTHON3_VERSION)m \
++ gcc -shared -pthread -fPIC python3/stfl_wrap.c -I$(shell python3 -c "from distutils.sysconfig import get_python_inc ; print(get_python_inc())") \
+ -I. libstfl.a -lncursesw -o python3/_stfl.so
+ cd python3 && python3 -c 'import stfl'
+