summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
Diffstat (limited to 'libraries')
-rw-r--r--libraries/Impacket/Impacket.SlackBuild71
-rw-r--r--libraries/Impacket/Impacket.info8
-rw-r--r--libraries/Impacket/README9
-rw-r--r--libraries/Impacket/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/libraries/Impacket/Impacket.SlackBuild b/libraries/Impacket/Impacket.SlackBuild
new file mode 100644
index 0000000000..90cdbd1986
--- /dev/null
+++ b/libraries/Impacket/Impacket.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for Impacket.
+#
+# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=Impacket
+VERSION=0.9.6.0
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="LICENSE PKG-INFO README"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py bdist
+tar zxvf dist/$PRGNAM-$VERSION.linux-i686.tar.gz -C $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/Impacket/Impacket.info b/libraries/Impacket/Impacket.info
new file mode 100644
index 0000000000..0d80e30d40
--- /dev/null
+++ b/libraries/Impacket/Impacket.info
@@ -0,0 +1,8 @@
+PRGNAM="Impacket"
+VERSION="0.9.6.0"
+HOMEPAGE="http://oss.coresecurity.com/projects/impacket.html"
+DOWNLOAD="http://oss.coresecurity.com/repo/Impacket-0.9.6.0.tar.gz"
+MD5SUM="6393804c7b88bca89cf7516214a61033"
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="dsomero"
diff --git a/libraries/Impacket/README b/libraries/Impacket/README
new file mode 100644
index 0000000000..00e4b5f792
--- /dev/null
+++ b/libraries/Impacket/README
@@ -0,0 +1,9 @@
+Impacket is a collection of Python classes focused on providing access
+to network packets. Impacket allows Python developers to craft and
+decode network packets in simple and consistent manner. It includes
+support for low-level protocols such as IP, UDP and TCP, as well as
+higher-level protocols such as NMB and SMB. Impacket is highly effective
+when used in conjunction with a packet capture utility or package such as
+Pcapy. Packets can be constructed from scratch, as well as parsed from
+raw data. Furthermore, the object oriented API makes it simple to work
+with deep protocol hierarchies.
diff --git a/libraries/Impacket/slack-desc b/libraries/Impacket/slack-desc
new file mode 100644
index 0000000000..dc4ba0f9ed
--- /dev/null
+++ b/libraries/Impacket/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+Impacket: Impacket (Python access to network packets)
+Impacket:
+Impacket: Impacket is a collection of Python classes focused on providing access
+Impacket: to network packets. Impacket allows Python developers to craft and
+Impacket: decode network packets in simple and consistent manner. It includes
+Impacket: support for low-level protocols such as IP, UDP and TCP, as well as
+Impacket: higher-level protocols such as NMB and SMB.
+Impacket:
+Impacket:
+Impacket:
+Impacket: