summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
Diffstat (limited to 'libraries')
-rw-r--r--libraries/bsddb3/README12
-rw-r--r--libraries/bsddb3/bsddb3.SlackBuild48
-rw-r--r--libraries/bsddb3/bsddb3.info8
-rw-r--r--libraries/bsddb3/slack-desc19
4 files changed, 87 insertions, 0 deletions
diff --git a/libraries/bsddb3/README b/libraries/bsddb3/README
new file mode 100644
index 0000000000..f23c3aaeda
--- /dev/null
+++ b/libraries/bsddb3/README
@@ -0,0 +1,12 @@
+Python interface for Berkeley DB
+
+This module provides a nearly complete wrapping of the
+Oracle/Sleepycat C API for the Database Environment, Database,
+Cursor, Sequence and Transaction objects, and each of these is
+exposed as a Python type in the bsddb3.db module. The database
+objects can use various access methods: btree, hash, recno, and
+queue. Complete support of Berkeley DB distributed transactions.
+Complete support for Berkeley DB Replication Manager. Complete
+support for Berkeley DB Base Replication. Support for RPC.
+
+This optionally can use pysetuptools.
diff --git a/libraries/bsddb3/bsddb3.SlackBuild b/libraries/bsddb3/bsddb3.SlackBuild
new file mode 100644
index 0000000000..761f4c44b2
--- /dev/null
+++ b/libraries/bsddb3/bsddb3.SlackBuild
@@ -0,0 +1,48 @@
+#!/bin/sh
+# Slackware build script for bsddb3
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=bsddb3
+VERSION=${VERSION:-4.7.6}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/bsddb3/bsddb3.info b/libraries/bsddb3/bsddb3.info
new file mode 100644
index 0000000000..a1cd7c7075
--- /dev/null
+++ b/libraries/bsddb3/bsddb3.info
@@ -0,0 +1,8 @@
+PRGNAM="bsddb3"
+VERSION="4.7.6"
+HOMEPAGE="http://www.jcea.es/programacion/pybsddb.htm"
+DOWNLOAD="http://pypi.python.org/packages/source/b/bsddb3/bsddb3-4.7.6.tar.gz"
+MD5SUM="53c06e0247b2aa4d8523d52e53378cb5"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="rworkman"
diff --git a/libraries/bsddb3/slack-desc b/libraries/bsddb3/slack-desc
new file mode 100644
index 0000000000..9b3efc3db9
--- /dev/null
+++ b/libraries/bsddb3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+bsddb3: bsddb3 (Python interface for Berkeley DB)
+bsddb3:
+bsddb3: This module provides a nearly complete wrapping of the
+bsddb3: Oracle/Sleepycat C API for the Database Environment, Database, Cursor,
+bsddb3: Sequence and Transaction objects, and each of these is exposed as a
+bsddb3: Python type in the bsddb3.db module. The database objects can use
+bsddb3: various access methods: btree, hash, recno, and queue. Complete
+bsddb3: support of Berkeley DB distributed transactions.
+bsddb3:
+bsddb3: Homepage: http://www.jcea.es/programacion/pybsddb.htm
+bsddb3: