summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
Diffstat (limited to 'libraries')
-rw-r--r--libraries/foolscap/README8
-rw-r--r--libraries/foolscap/foolscap.SlackBuild88
-rw-r--r--libraries/foolscap/foolscap.info10
-rw-r--r--libraries/foolscap/slack-desc19
4 files changed, 0 insertions, 125 deletions
diff --git a/libraries/foolscap/README b/libraries/foolscap/README
deleted file mode 100644
index 1a59cf9780..0000000000
--- a/libraries/foolscap/README
+++ /dev/null
@@ -1,8 +0,0 @@
-"Foolscap" is an RPC protocol for Python+Twisted, providing a
-capability-based security model and flexible serialization. It
-is intended to replace Twisted's native "Perspective Broker"
-RPC system. Foolscap has been under development (on and off)
-by Brian Warner for several years.
-
-This package requires pysetuptools, python-twisted and
-zope.interface.
diff --git a/libraries/foolscap/foolscap.SlackBuild b/libraries/foolscap/foolscap.SlackBuild
deleted file mode 100644
index 9fc65a1b60..0000000000
--- a/libraries/foolscap/foolscap.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for foolscap.
-
-# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Originally written by Marco Bonetti - Thanks!
-# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
-
-PRGNAM=foolscap
-VERSION=${VERSION:-0.6.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="LICENSE README"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/slack-desc > $PKG/usr/doc/$PRGNAM-$VERSION/slack-desc
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/foolscap/foolscap.info b/libraries/foolscap/foolscap.info
deleted file mode 100644
index 8f04e54966..0000000000
--- a/libraries/foolscap/foolscap.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="foolscap"
-VERSION="0.6.3"
-HOMEPAGE="http://foolscap.lothar.com/trac"
-DOWNLOAD="http://foolscap.lothar.com/releases/foolscap-0.6.3.tar.gz"
-MD5SUM="38782e3b64d3a0beea1ae03dd9ca137f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Markus Reichelt"
-EMAIL="slackbuilds@mareichelt.de"
-APPROVED="dsomero"
diff --git a/libraries/foolscap/slack-desc b/libraries/foolscap/slack-desc
deleted file mode 100644
index 4ccde7bbc0..0000000000
--- a/libraries/foolscap/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler----------------------------------------------------|
-foolscap: foolscap (RPC protocol for Python+Twisted)
-foolscap:
-foolscap: Foolscap is an RPC protocol for Python+Twisted, providing a
-foolscap: capability-based security model and flexible serialization. It is
-foolscap: intended to replace Twisted's native "Perspective Broker" RPC
-foolscap: system.
-foolscap:
-foolscap: Homepage: http://foolscap.lothar.com/trac
-foolscap:
-foolscap:
-foolscap: