summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
Diffstat (limited to 'libraries')
-rw-r--r--libraries/MyGUI/MyGUI.SlackBuild117
-rw-r--r--libraries/MyGUI/MyGUI.info10
-rw-r--r--libraries/MyGUI/README2
-rw-r--r--libraries/MyGUI/doinst.sh3
-rw-r--r--libraries/MyGUI/slack-desc19
5 files changed, 151 insertions, 0 deletions
diff --git a/libraries/MyGUI/MyGUI.SlackBuild b/libraries/MyGUI/MyGUI.SlackBuild
new file mode 100644
index 0000000000..aeb3eb3049
--- /dev/null
+++ b/libraries/MyGUI/MyGUI.SlackBuild
@@ -0,0 +1,117 @@
+#!/bin/sh
+
+# Slackware build script for MyGUI
+
+# Copyright Talos Thoren <talosthoren@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=MyGUI
+VERSION=${VERSION:-3.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+UNZIPDIR=$TMP/$PRGNAM\_$VERSION
+DOCS="$UNZIPDIR/ChangeLog.txt $UNZIPDIR/COPYING.LESSER $UNZIPDIR/Readme.txt"
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip -o $CWD/$PRGNAM\_$VERSION
+cd $PRGNAM\_$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i '71 i set(MYGUI_GCC_VISIBILITY_FLAGS "")' CMakeLists.txt
+sed -i 's/\${OIS_LIBRARIES}/${OIS_LIBRARIES} boost_system/g' Common/CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DMYGUI_INSTALL_TOOLS=TRUE \
+ -DMYGUI_INSTALL_DOCS=FALSE \
+ -DMYGUI_INSTALL_SAMPLES=FALSE \
+ -DMYGUI_INSTALL_MEDIA=TRUE \
+ -DMYGUI_STATIC=FALSE \
+ -DMYGUI_USE_FREETYPE=TRUE \
+ -DMYGUI_BUILD_PLUGINS=TRUE \
+ -DMYGUI_BUILD_TOOLS=TRUE \
+ -DMYGUI_BUILD_WRAPPER=FALSE \
+ ..
+
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Ensure that the libraries are installed in the correct directory on 64-bit
+if [ "$ARCH" = "x86_64" ]; then
+ mv $PKG/usr/lib $PKG/usr/lib${LIBDIRSUFFIX}
+ sed -i '3 s/\/lib/\/lib64/' $PKG/usr/lib$LIBDIRSUFFIX/pkgconfig/MYGUI.pc
+fi
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/MyGUI/MyGUI.info b/libraries/MyGUI/MyGUI.info
new file mode 100644
index 0000000000..16600ab7ce
--- /dev/null
+++ b/libraries/MyGUI/MyGUI.info
@@ -0,0 +1,10 @@
+PRGNAM="MyGUI"
+VERSION="3.2.0"
+HOMEPAGE="http://mygui.info"
+DOWNLOAD="http://nchc.dl.sourceforge.net/project/my-gui/MyGUI/MyGUI_3.2.0/MyGUI_3.2.0.zip"
+MD5SUM="7c20486a0db82f497d8b7c5300613b61"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="ois ogre"
+MAINTAINER="Talos Thoren"
+EMAIL="talosthoren@gmail.com"
diff --git a/libraries/MyGUI/README b/libraries/MyGUI/README
new file mode 100644
index 0000000000..c45b37cf1a
--- /dev/null
+++ b/libraries/MyGUI/README
@@ -0,0 +1,2 @@
+MyGUI is a library for creating Graphical User Interfaces (GUIs) for games and 3D applications.
+The main goals of mygui are: speed, flexibility and ease of use.
diff --git a/libraries/MyGUI/doinst.sh b/libraries/MyGUI/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/libraries/MyGUI/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/libraries/MyGUI/slack-desc b/libraries/MyGUI/slack-desc
new file mode 100644
index 0000000000..a3b9f4c848
--- /dev/null
+++ b/libraries/MyGUI/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+MyGUI: MyGUI (fast, simple and flexible GUI)
+MyGUI:
+MyGUI: MyGUI is a library for creating Graphical User Interfaces (GUIs) for
+MyGUI: games and 3D applications. The main goals of MyGUI are: speed,
+MyGUI: flexibility and ease of use.
+MyGUI:
+MyGUI: URL: http://mygui.info/
+MyGUI:
+MyGUI:
+MyGUI:
+MyGUI: