summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
Diffstat (limited to 'libraries')
-rw-r--r--libraries/libpgf/libpgf.SlackBuild43
-rw-r--r--libraries/libpgf/libpgf.info6
2 files changed, 18 insertions, 31 deletions
diff --git a/libraries/libpgf/libpgf.SlackBuild b/libraries/libpgf/libpgf.SlackBuild
index d60d36dfc1..77a193f20c 100644
--- a/libraries/libpgf/libpgf.SlackBuild
+++ b/libraries/libpgf/libpgf.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2012 Willy Sudiarto Raharjo <willysr@slackware-id.org>
+# Copyright 2012-2014 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -20,12 +20,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Changelog
-# June, 8, 2012 : Initial Release
-# July, 10, 2012: Upgraded to 6.12.24
-
PRGNAM=libpgf
-VERSION=6.12.24
+VERSION=${VERSION:-6.14.12}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,7 +35,7 @@ fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-${PRGNAM}
+PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
@@ -61,21 +57,18 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf ${PRGNAM}-${VERSION}
-tar xvf $CWD/${PRGNAM}-$VERSION-src.tar.gz
-cd ${PRGNAM}
-
-# Make sure ownerships and permissions are sane:
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-src-$VERSION.tar.gz
+cd $PRGNAM
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# So strange that i have to add this one line to fix the permission problem
-chmod 755 autogen.sh
-
+fromdos < configure.ac > configure.ac.new
+mv configure.ac.new configure.ac
./autogen.sh
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -85,27 +78,21 @@ CFLAGS="$SLKCFLAGS" \
--disable-static \
--build=$ARCH-slackware-linux
-# Build and install:
-make || make -j1
+make
make install DESTDIR=$PKG
-# Strip binaries:
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# Compress and link manpages, if any:
mv $PKG/usr/share/man $PKG/usr/man
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-# Add a documentation directory:
-mkdir -p $PKG/usr/doc/${PRGNAM}-$VERSION
-cp -a \
- AUTHORS COPYING INSTALL NEWS README \
- $PKG/usr/doc/${PRGNAM}-$VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING INSTALL README $PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-cd $TMP/package-${PRGNAM}
-/sbin/makepkg -l y -c n $OUTPUT/${PRGNAM}-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libpgf/libpgf.info b/libraries/libpgf/libpgf.info
index 5bdee8db4c..10c538de6d 100644
--- a/libraries/libpgf/libpgf.info
+++ b/libraries/libpgf/libpgf.info
@@ -1,8 +1,8 @@
PRGNAM="libpgf"
-VERSION="6.12.24"
+VERSION="6.14.12"
HOMEPAGE="http://www.libpgf.org"
-DOWNLOAD="http://downloads.sourceforge.net/libpgf/libpgf-6.12.24-src.tar.gz"
-MD5SUM="49ae25a63804273f0c6875f477b5f6d2"
+DOWNLOAD="http://sourceforge.net/projects/libpgf/files/libpgf/6.14.12-latest/libpgf-src-6.14.12.tar.gz"
+MD5SUM="a2b13832e23ad9026bd249d57b6c26da"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""