summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
Diffstat (limited to 'libraries')
-rw-r--r--libraries/libtins/README6
-rw-r--r--libraries/libtins/libdir.patch49
-rw-r--r--libraries/libtins/libtins.SlackBuild105
-rw-r--r--libraries/libtins/libtins.info10
-rw-r--r--libraries/libtins/slack-desc19
5 files changed, 189 insertions, 0 deletions
diff --git a/libraries/libtins/README b/libraries/libtins/README
new file mode 100644
index 0000000000..04529d4b88
--- /dev/null
+++ b/libraries/libtins/README
@@ -0,0 +1,6 @@
+libtins is a high-level, multiplatform C++ network packet sniffing
+and crafting library.
+
+Its main purpose is to provide the C++ developer an easy, efficient,
+platform and endianess-independent way to create tools which need to
+send, receive and manipulate specially crafted packets.
diff --git a/libraries/libtins/libdir.patch b/libraries/libtins/libdir.patch
new file mode 100644
index 0000000000..b1252d88ad
--- /dev/null
+++ b/libraries/libtins/libdir.patch
@@ -0,0 +1,49 @@
+--- CMakeLists.txt.stock 2018-04-09 18:19:55.192971704 +0200
++++ CMakeLists.txt 2018-04-09 18:20:50.347434703 +0200
+@@ -224,18 +224,19 @@
+ )
+ ENDIF(DOXYGEN_FOUND)
+
+-# The library output directory
+-SET(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR}/lib)
+-SET(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR}/lib)
+-
+ # Configuration file
+ CONFIGURE_FILE(
+ "${PROJECT_SOURCE_DIR}/include/tins/config.h.in"
+ "${PROJECT_SOURCE_DIR}/include/tins/config.h"
+ )
+
++IF(NOT CMAKE_INSTALL_LIBDIR)
++ set(CMAKE_INSTALL_LIBDIR lib)
++ENDIF()
++# The library output directory
++SET(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR}/${CMAKE_INSTALL_LIBDIR})
++SET(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR}/${CMAKE_INSTALL_LIBDIR})
+ # Support for pkg-config
+-SET(CMAKE_INSTALL_LIBDIR lib)
+ SET(pkgconfig_prefix ${CMAKE_INSTALL_PREFIX})
+ SET(pkgconfig_exec_prefix ${CMAKE_INSTALL_PREFIX})
+ SET(pkgconfig_libdir ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
+
+--- src/CMakeLists.txt.stock 2018-04-09 18:21:00.281518096 +0200
++++ src/CMakeLists.txt 2018-04-09 18:21:40.244853572 +0200
+@@ -219,8 +219,8 @@
+ INSTALL(
+ TARGETS tins
+ EXPORT libtinsTargets
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ COMPONENT dev
+ )
+
+@@ -233,4 +233,4 @@
+ ENDFOREACH(HEADER)
+ ENDMACRO()
+
+-INSTALL_HEADERS_WITH_DIRECTORY(${HEADERS})
+\ No newline at end of file
++INSTALL_HEADERS_WITH_DIRECTORY(${HEADERS})
+
diff --git a/libraries/libtins/libtins.SlackBuild b/libraries/libtins/libtins.SlackBuild
new file mode 100644
index 0000000000..52d6c7346e
--- /dev/null
+++ b/libraries/libtins/libtins.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/sh
+
+# Slackware build script for LIBTINS
+
+# Copyright 2018 Nicolas Piatto <nico@lodpp.net> FRANCE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# 07/Apr/2018 * First version
+
+PRGNAM=libtins
+VERSION=${VERSION:-4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fixup for hardcoded libdir
+patch -p0 < $CWD/libdir.patch
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib$LIBDIRSUFFIX \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat CHANGES.md > $PKG/usr/doc/$PRGNAM-$VERSION/CHANGES.md
+cat CONTRIBUTING.md > $PKG/usr/doc/$PRGNAM-$VERSION/CONTRIBUTING.md
+cat README.md > $PKG/usr/doc/$PRGNAM-$VERSION/README.md
+cat LICENSE > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
+cat THANKS > $PKG/usr/doc/$PRGNAM-$VERSION/THANKS
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libtins/libtins.info b/libraries/libtins/libtins.info
new file mode 100644
index 0000000000..bdc24d0253
--- /dev/null
+++ b/libraries/libtins/libtins.info
@@ -0,0 +1,10 @@
+PRGNAM="libtins"
+VERSION="4.0"
+HOMEPAGE="http://libtins.github.io/"
+DOWNLOAD="https://github.com/mfontanini/libtins/archive/v4.0/libtins-4.0.tar.gz"
+MD5SUM="10e6c8d5b7ec862f0bebad26859c270a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Nicolas Piatto"
+EMAIL="nico@lodpp.net"
diff --git a/libraries/libtins/slack-desc b/libraries/libtins/slack-desc
new file mode 100644
index 0000000000..be4c09b4bc
--- /dev/null
+++ b/libraries/libtins/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libtins: libtins (network packet sniffing library)
+libtins:
+libtins: libtins is a high-level, multiplatform C++ network packet sniffing
+libtins: and crafting library.
+libtins:
+libtins: Its main purpose is to provide the C++ developer an easy, efficient,
+libtins: platform and endianess-independent way to create tools which need to
+libtins: send, receive and manipulate specially crafted packets.
+libtins:
+libtins:
+libtins: