summaryrefslogtreecommitdiffstats
path: root/misc/chm2pdf/chm2pdf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/chm2pdf/chm2pdf.SlackBuild')
-rw-r--r--misc/chm2pdf/chm2pdf.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/misc/chm2pdf/chm2pdf.SlackBuild b/misc/chm2pdf/chm2pdf.SlackBuild
index 58f2513a89..a5911eb4f4 100644
--- a/misc/chm2pdf/chm2pdf.SlackBuild
+++ b/misc/chm2pdf/chm2pdf.SlackBuild
@@ -27,15 +27,13 @@
PRGNAM=chm2pdf
VERSION=${VERSION:-0.9.1}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -65,6 +63,9 @@ find . \
# Patch from Gentoo: http://bugs.gentoo.org/205208
cat $CWD/patches/tempdir.patch | patch -p1
+# patch to fix problem with file name with spaces
+cat $CWD/patches/filename.patch | patch -p1
+
python setup.py build
python setup.py install --root $PKG