summaryrefslogtreecommitdiffstats
path: root/misc/chm2pdf/chm2pdf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/chm2pdf/chm2pdf.SlackBuild')
-rw-r--r--misc/chm2pdf/chm2pdf.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/misc/chm2pdf/chm2pdf.SlackBuild b/misc/chm2pdf/chm2pdf.SlackBuild
index 9411605ee0..0e60c0ea6f 100644
--- a/misc/chm2pdf/chm2pdf.SlackBuild
+++ b/misc/chm2pdf/chm2pdf.SlackBuild
@@ -27,7 +27,7 @@
PRGNAM=chm2pdf
VERSION=${VERSION:-0.9.1}
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -50,6 +50,11 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Apply a patch againsts a security problem with temporary dirs.
+# Bug report from Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=501959
+# Patch from Gentoo: http://bugs.gentoo.org/205208
+cat $CWD/patches/tempdir.patch | patch -p1
+
python setup.py build
python setup.py install --root $PKG
@@ -68,4 +73,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}