summaryrefslogtreecommitdiffstats
path: root/misc/conkyforecast/conkyforecast.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/conkyforecast/conkyforecast.SlackBuild')
-rw-r--r--misc/conkyforecast/conkyforecast.SlackBuild17
1 files changed, 3 insertions, 14 deletions
diff --git a/misc/conkyforecast/conkyforecast.SlackBuild b/misc/conkyforecast/conkyforecast.SlackBuild
index 3e36e5defc..8a3257fdfb 100644
--- a/misc/conkyforecast/conkyforecast.SlackBuild
+++ b/misc/conkyforecast/conkyforecast.SlackBuild
@@ -5,19 +5,11 @@
# Written by M.Dinslage (daedra1980@gmail.com)
PRGNAM=conkyforecast
-VERSION=${VERSION:-2.09}
+VERSION=${VERSION:-2.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
+ARCH=noarch
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
@@ -30,7 +22,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf src
-tar xvf $CWD/conkyforecast_2.09.tar.gz
+tar xvf $CWD/${PRGNAM}_${VERSION}.tar.gz
cd src
chown -R root:root .
find . \
@@ -44,9 +36,6 @@ sed -i 's,/usr/share/fonts/truetype/conkyforecast,/usr/share/fonts/TTF,g' setup.
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
# remove font .sfd files, they shouldn't be needed
rm -r $PKG/usr/share/fonts/TTF/*.tar.gz