summaryrefslogtreecommitdiffstats
path: root/misc/funny-manpages/funny-manpages.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/funny-manpages/funny-manpages.SlackBuild')
-rw-r--r--misc/funny-manpages/funny-manpages.SlackBuild48
1 files changed, 18 insertions, 30 deletions
diff --git a/misc/funny-manpages/funny-manpages.SlackBuild b/misc/funny-manpages/funny-manpages.SlackBuild
index 65e8fb25cc..209cedf7f1 100644
--- a/misc/funny-manpages/funny-manpages.SlackBuild
+++ b/misc/funny-manpages/funny-manpages.SlackBuild
@@ -26,15 +26,13 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=funny-manpages
-VERSION=${VERSION:-1.3.5}
-SRC_VERSION=$( echo $VERSION | cut -d. -f1,2 )
-DEB_VERSION=5
-
-ARCH=noarch
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
+ARCH=noarch
+
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
@@ -52,45 +50,35 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}_$SRC_VERSION.orig.tar.gz
-cd $PRGNAM-$SRC_VERSION.orig
+rm -rf $PRGNAM
+tar xvf $CWD/${PRGNAM}_$VERSION.orig.tar.gz
+cd $PRGNAM
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Patch the manpages to the latest version.
-patch -p1 < $CWD/${PRGNAM}_$SRC_VERSION-$DEB_VERSION.diff
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Create the directories we need
-mkdir -p $PKG/usr/man/man{1,3,6,7}
+make install DESTDIR=$PKG
-for manpage in $(echo *fun); do
- section=$(echo $manpage | awk -F. '{print $2}' | colrm 2 4)
- install -m 0644 $manpage $PKG/usr/man/man$section/$manpage
-done
+mv $PKG/usr/share/man $PKG/usr
+rm -rf $PKG/usr/share
# Move date.1fun over to mansection 6. It is kinda screwing with upstream,
# but right now causes a conflict with the systems date(1)
( cd $PKG/usr/man/man1
- ln -sf grope.1fun egrope.1fun
- ln -sf grope.1fun fgrope.1fun
mv date.1fun ../man6/date.6fun
)
# Add custom noobfarm manpage. Thanks to Matt Hayes.
-install -m 0644 $CWD/noobfarm.7 $PKG/usr/man/man7/noobfarm.7fun
+install -m644 -D $CWD/noobfarm.7 $PKG/usr/man/man7/noobfarm.7fun
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a debian/README.Debian debian/changelog debian/copyright \
+cp -a CHANGELOG LICENSE README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild