summaryrefslogtreecommitdiffstats
path: root/misc/lppf
diff options
context:
space:
mode:
Diffstat (limited to 'misc/lppf')
-rw-r--r--misc/lppf/Makefile.diff.gzbin0 -> 597 bytes
-rw-r--r--misc/lppf/README6
-rw-r--r--misc/lppf/braces.diff.gzbin0 -> 374 bytes
-rw-r--r--misc/lppf/lppf.SlackBuild100
-rw-r--r--misc/lppf/lppf.info10
-rw-r--r--misc/lppf/slack-desc19
6 files changed, 135 insertions, 0 deletions
diff --git a/misc/lppf/Makefile.diff.gz b/misc/lppf/Makefile.diff.gz
new file mode 100644
index 0000000000..2dac15bc03
--- /dev/null
+++ b/misc/lppf/Makefile.diff.gz
Binary files differ
diff --git a/misc/lppf/README b/misc/lppf/README
new file mode 100644
index 0000000000..412a140600
--- /dev/null
+++ b/misc/lppf/README
@@ -0,0 +1,6 @@
+lppf is an application for handling PPF patches in Linux. PPF patches are
+often very small and are used for correcting a previously released movie
+or an ISO, so that users won't have to download everything again.
+
+To build the debugging symbols use:
+ DEBUG=1 ./lppf.SlackBuild
diff --git a/misc/lppf/braces.diff.gz b/misc/lppf/braces.diff.gz
new file mode 100644
index 0000000000..7f84168f2b
--- /dev/null
+++ b/misc/lppf/braces.diff.gz
Binary files differ
diff --git a/misc/lppf/lppf.SlackBuild b/misc/lppf/lppf.SlackBuild
new file mode 100644
index 0000000000..7ee052bde5
--- /dev/null
+++ b/misc/lppf/lppf.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/sh
+
+# Slackware build script for lppf
+
+# Copyright 2016 Hunter Sezen California, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=lppf
+VERSION=${VERSION:-0.1_rc1}
+SRCVER=$(echo $VERSION | tr _ -)
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+DEBUG=${DEBUG:-0}
+if [ "$DEBUG" = "1" ]; then
+ SLKCFLAGS=$(echo $SLKCFLAGS | sed 's/-O2/-O0 -g/')
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
+cd $PRGNAM-$SRCVER
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+zcat $CWD/Makefile.diff.gz | patch -p1
+zcat $CWD/braces.diff.gz | patch -p1
+
+CFLAGS="$SLKCFLAGS" make
+
+make install \
+ PREFIX=/usr \
+ DOCDIR=/usr/doc/$PRGNAM-$VERSION \
+ DESTDIR=$PKG
+
+if [ "$DEBUG" = "0" ]; then
+ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/misc/lppf/lppf.info b/misc/lppf/lppf.info
new file mode 100644
index 0000000000..36db5baaaf
--- /dev/null
+++ b/misc/lppf/lppf.info
@@ -0,0 +1,10 @@
+PRGNAM="lppf"
+VERSION="0.1_rc1"
+HOMEPAGE="https://sourceforge.net/projects/lppf/"
+DOWNLOAD="http://downloads.sourceforge.net/project/lppf/lppf-0.1_rc1/lppf-0.1_rc1/lppf-0.1-rc1.tar.gz"
+MD5SUM="f85b14efb64378fe016a104f09c36e6d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Hunter Sezen"
+EMAIL="ovariegata@yahoo.com"
diff --git a/misc/lppf/slack-desc b/misc/lppf/slack-desc
new file mode 100644
index 0000000000..0ccb5fac09
--- /dev/null
+++ b/misc/lppf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+lppf: lppf (Linux PPF Patcher)
+lppf:
+lppf: lppf is an application for handling PPF patches in Linux. PPF patches
+lppf: are often very small and are used for correcting a previously
+lppf: released movie or an ISO, so that users won't have to download
+lppf: everything again.
+lppf:
+lppf: Homepage: https://sourceforge.net/projects/lppf/
+lppf:
+lppf:
+lppf: