summaryrefslogtreecommitdiffstats
path: root/misc/xapian-omega
diff options
context:
space:
mode:
Diffstat (limited to 'misc/xapian-omega')
-rw-r--r--misc/xapian-omega/README4
-rw-r--r--misc/xapian-omega/doinst.sh14
-rw-r--r--misc/xapian-omega/slack-desc19
-rw-r--r--misc/xapian-omega/xapian-omega.SlackBuild139
-rw-r--r--misc/xapian-omega/xapian-omega.info10
5 files changed, 186 insertions, 0 deletions
diff --git a/misc/xapian-omega/README b/misc/xapian-omega/README
new file mode 100644
index 0000000000..4ca89f3a85
--- /dev/null
+++ b/misc/xapian-omega/README
@@ -0,0 +1,4 @@
+Omega is an application built on Xapian, consisting
+of indexers and a CGI search frontend.
+
+This requires xapian-core.
diff --git a/misc/xapian-omega/doinst.sh b/misc/xapian-omega/doinst.sh
new file mode 100644
index 0000000000..7ece5d2656
--- /dev/null
+++ b/misc/xapian-omega/doinst.sh
@@ -0,0 +1,14 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+config etc/omega.conf.new
+
diff --git a/misc/xapian-omega/slack-desc b/misc/xapian-omega/slack-desc
new file mode 100644
index 0000000000..3da83b63cc
--- /dev/null
+++ b/misc/xapian-omega/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+xapian-omega: xapian-omega (CGI search frontend and indexers built on Xapian)
+xapian-omega:
+xapian-omega: Omega is a CGI application which uses the Xapian Information Retrieval
+xapian-omega: library to index and search collections of documents.
+xapian-omega:
+xapian-omega: Homepage: http://www.xapian.org/
+xapian-omega:
+xapian-omega:
+xapian-omega:
+xapian-omega:
+xapian-omega:
diff --git a/misc/xapian-omega/xapian-omega.SlackBuild b/misc/xapian-omega/xapian-omega.SlackBuild
new file mode 100644
index 0000000000..5f4ea65163
--- /dev/null
+++ b/misc/xapian-omega/xapian-omega.SlackBuild
@@ -0,0 +1,139 @@
+#!/bin/sh
+
+# Slackware build script for xapian-omega
+
+# Written by Charles (SlackBuilds@catcons.co.uk)
+
+# Permission to use, copy, modify, and distribute this software for
+# any purpose with or without fee is hereby granted, provided that
+# the above copyright notice and this permission notice appear in all
+# copies.
+#
+# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+# IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
+# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
+# USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
+# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+# SUCH DAMAGE.
+
+# Quite modified by Robby Workman <rworkman@slackbuilds.org>
+
+PRGNAM=xapian-omega
+VERSION=${VERSION:-1.2.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+HTTPD_DIR=${HTTPD_DIR:-/srv/httpd}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --disable-static \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+# Install (but don't clobber) a config file
+mv $PKG/etc/omega.conf $PKG/etc/omega.conf.new
+
+# Handle the CGI stuff
+mkdir -p $PKG/var/lib/omega/templates $PKG/$HTTPD_DIR/{cgi-bin,icons/omega}
+cp -a templates/* $PKG/var/lib/omega/templates
+mv $PKG/usr/lib${LIBDIRSUFFIX}/xapian-omega/bin/omega $PKG/$HTTPD_DIR/cgi-bin
+cp -a images/* $PKG/$HTTPD_DIR/icons/omega
+
+# This Vim syntax file is nice to have
+mkdir -p $PKG/usr/share/vim/vim72/syntax
+cp -a extra/omegascript.vim $PKG/usr/share/vim/vim72/syntax
+
+# Create the otherwise missing directories listed in /etc/omega
+mkdir -p $PKG/var/lib/omega/{cdb,data} $PKG/var/log/omega
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING ChangeLog INSTALL NEWS README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# !! TODO !! #
+# I'm leaving these next few lines commented, because, well, to be honest,
+# I don't like them. I don't see a compelling reason to change the structure
+# that upstream installs (and recommends in the .spec file shipped with the
+# source). If there's some compelling reason to change (and harmony with
+# a Debian package does not qualify), then I'll be happy to reconsider.
+# -- rworkman
+#
+# Adjustments to harmonise with the Debian package created by Xapian developer Olly
+#mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/examples
+#mv $PKG/usr/bin/{dbi2omega,htdig2omega,mbox2omega} $PKG/usr/doc/$PRGNAM-$VERSION/examples
+#mv $PKG/usr/share/omega/* $PKG/usr/doc/$PRGNAM-$VERSION/examples
+# Extra example (not in Olly's Debian package)
+#mv $PKG/usr/lib${LIBDIRSUFFIX}/xapian-omega/bin/outlookmsg2html $PKG/usr/doc/$PRGNAM-$VERSION/examples
+# !! END TODO !! #
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/misc/xapian-omega/xapian-omega.info b/misc/xapian-omega/xapian-omega.info
new file mode 100644
index 0000000000..f8259b9bc9
--- /dev/null
+++ b/misc/xapian-omega/xapian-omega.info
@@ -0,0 +1,10 @@
+PRGNAM="xapian-omega"
+VERSION="1.2.4"
+HOMEPAGE="http://www.xapian.org/"
+DOWNLOAD="http://oligarchy.co.uk/xapian/1.2.4/xapian-omega-1.2.4.tar.gz"
+MD5SUM="b20262101ffbd4aec457a34241834a72"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Charles"
+EMAIL="SlackBuilds@catcons.co.uk"
+APPROVED="rworkman"