summaryrefslogtreecommitdiffstats
path: root/multimedia/Gem/Gem.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/Gem/Gem.SlackBuild')
-rw-r--r--multimedia/Gem/Gem.SlackBuild34
1 files changed, 21 insertions, 13 deletions
diff --git a/multimedia/Gem/Gem.SlackBuild b/multimedia/Gem/Gem.SlackBuild
index 3ebe9c5f87..16a4e081f6 100644
--- a/multimedia/Gem/Gem.SlackBuild
+++ b/multimedia/Gem/Gem.SlackBuild
@@ -3,10 +3,14 @@
#
# Michales (clavisound) Michaloudes korgie@gmail.com <2017>
+# 20220214 bkw: Modified by SlackBuilds.org:
+# - updated for v0.94, as 0.93.3 won't build on Slackware 15.0.
+# - moved pkg-config stuff to proper place (/usr/lib64 on x86_64).
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=Gem
-VERSION=${VERSION:-0.93.3}
+VERSION=${VERSION:-0.94}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -19,9 +23,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -47,18 +48,21 @@ fi
set -e
+ZIPFILE="$CWD/Gem[v0.94](Sources).dek"
+[ -e "$ZIPFILE" ] || ZIPFILE="$CWD/Gem%5Bv0.94%5D%28Sources%29.dek"
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM
+unzip $ZIPFILE
+cd $PRGNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# I think useless
# patch externals/Gem/configure.ac < $CWD/change_gem_configure_file.patch
@@ -66,8 +70,10 @@ find -L . \
# Cannot manage to compile with v4l2
# sed -i "s|linux/videodev\.h|libv4l1-videodev.h|" configure || exit 1
+./autogen.sh
+
CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS"
+CXXFLAGS="$SLKCFLAGS -std=c++11 -fpermissive" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
@@ -87,10 +93,12 @@ make
# make install DESTDIR=$PKG/usr/lib${LIBDIRSUFFIX}/pd/extra
# will go to $PKG/usr/lib${LIBDIRSUFFIX}/$PRGNAM
-make install DESTDIR=$PKG
+make install-strip DESTDIR=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+if [ -n "$LIBDIRSUFFIX" ] ; then
+ mv $PKG/usr/lib/pkgconfig $PKG/usr/lib$LIBDIRSUFFIX
+fi
+rmdir $PKG/usr/lib 2>/dev/null || true # does nothing on 32-bit.
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION