summaryrefslogtreecommitdiffstats
path: root/multimedia/gaupol
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/gaupol')
-rw-r--r--multimedia/gaupol/README29
-rw-r--r--multimedia/gaupol/gaupol.SlackBuild49
-rw-r--r--multimedia/gaupol/gaupol.info12
3 files changed, 44 insertions, 46 deletions
diff --git a/multimedia/gaupol/README b/multimedia/gaupol/README
index 3129a19804..c04861dbc5 100644
--- a/multimedia/gaupol/README
+++ b/multimedia/gaupol/README
@@ -1,20 +1,15 @@
-Gaupol is an editor for text-based subtitle files. It supports multiple
-subtitle file formats and provides means of correcting texts and timing
-subtitles to match video. The user interface is designed with attention
-to batch processing of multiple documents and convenience of translating.
-
-Gaupol should run on all Unix-like (GNU/Linux, *BSD, etc.) operating systems
-and on Windows. Technically, it should run on Mac as well, but that has not
-been tested nor made convenient. Gaupol's user interface is based on the
-GTK+ toolkit and has been designed to best fit the GNOME desktop environment.
+Gaupol is an editor for text-based subtitle files. It supports
+multiple subtitle file formats and provides means of correcting
+texts and timing subtitles to match video. The user interface is
+designed with attention to batch processing of multiple documents and
+convenience of translating.
+
+Gaupol should run on all Unix-like (GNU/Linux, *BSD, etc.) operating
+systems and on Windows. Technically, it should run on Mac as well, but
+that has not been tested nor made convenient. Gaupol's user interface
+is based on the GTK+ toolkit and has been designed to best fit the
+GNOME desktop environment.
Optional dependencies are:
-- pyenchant 1.1.3 or greater is required for spell-checking.
- Additionally, spell-checking requires a dictionary, any of Aspell/Pspell,
- Ispell, MySpell, Uspell, Hspell or AppleSpell.
-
-- iso-codes, if available, will be used to translate script, language and
- country names.
-
-- MPlayer or VLC is recommended for preview.
+- MPlayer, mpv, or VLC is recommended for preview.
diff --git a/multimedia/gaupol/gaupol.SlackBuild b/multimedia/gaupol/gaupol.SlackBuild
index d87b1e7788..2ef3567e16 100644
--- a/multimedia/gaupol/gaupol.SlackBuild
+++ b/multimedia/gaupol/gaupol.SlackBuild
@@ -2,29 +2,33 @@
# Slackware build script for gaupol
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Written by Andre Barboza <bmg.andre@gmail.com>
-
+# All rights reserved.
+#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# 20220922 46and2: Updated version, new maintainer.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gaupol
-VERSION=${VERSION:-0.19.2}
+VERSION=${VERSION:-1.14.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -37,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -59,20 +60,22 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+python3 setup.py install --root=$PKG
-mkdir -p $PKG/usr
-python setup.py clean install --prefix=/usr --root=$PKG
+# pycache file has /tmp/SBo patch hardcoded, remove it and let it regenerate
+rm $PKG/usr/share/gaupol/extensions/custom-framerates/__pycache__/custom-framerates.cpython-*.pyc
mv $PKG/usr/share/man $PKG/usr
-find $PKG/usr/man -type f -exec gzip -9 {} \;
+find $PKG/usr/man -type f -exec gzip -9 {} \+
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING CREDITS INSTALL NEWS README TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.md COPYING NEWS.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/multimedia/gaupol/gaupol.info b/multimedia/gaupol/gaupol.info
index a7e9d5efc9..6ece9a8b22 100644
--- a/multimedia/gaupol/gaupol.info
+++ b/multimedia/gaupol/gaupol.info
@@ -1,10 +1,10 @@
PRGNAM="gaupol"
-VERSION="0.19.2"
+VERSION="1.14.1"
HOMEPAGE="https://github.com/otsaloma/gaupol"
-DOWNLOAD="https://github.com/otsaloma/gaupol/archive/0.19.2/gaupol-0.19.2.tar.gz"
-MD5SUM="bdebf0abcdd3ee6f22c9608c13dc1dc8"
+DOWNLOAD="https://github.com/otsaloma/gaupol/archive/1.14.1/gaupol-1.14.1.tar.gz"
+MD5SUM="fc45c20eb110528395bdea312a5153d1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Andre Barboza"
-EMAIL="bmg.andre@gmail.com"
+REQUIRES="gspell"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"