summaryrefslogtreecommitdiffstats
path: root/multimedia/picard/picard.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/picard/picard.SlackBuild')
-rw-r--r--multimedia/picard/picard.SlackBuild21
1 files changed, 7 insertions, 14 deletions
diff --git a/multimedia/picard/picard.SlackBuild b/multimedia/picard/picard.SlackBuild
index 14a9492ef6..563f8bc7b5 100644
--- a/multimedia/picard/picard.SlackBuild
+++ b/multimedia/picard/picard.SlackBuild
@@ -1,9 +1,9 @@
#!/bin/bash
-# Slackware build script for "picard".
+# Slackware build script for Picard
# Copyright 2014-2015 Marcel Saegebarth <marc@mos6581.de>
-# Copyright 2018 Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
+# Copyright 2018-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -28,7 +28,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=picard
-VERSION=${VERSION:-1.4.2}
+VERSION=${VERSION:-2.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -55,16 +52,12 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
fi
set -e
@@ -72,8 +65,8 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+rm -rf $PRGNAM-release-$VERSION
+tar xvf $CWD/$PRGNAM-release-$VERSION.tar.gz
cd $PRGNAM-release-$VERSION
chown -R root:root .
find -L . \
@@ -84,8 +77,8 @@ find -L . \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
-python setup.py build
-python setup.py install --root $PKG
+
+python3 setup.py install --root $PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true