summaryrefslogtreecommitdiffstats
path: root/multimedia/smplayer/smplayer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/smplayer/smplayer.SlackBuild')
-rw-r--r--multimedia/smplayer/smplayer.SlackBuild43
1 files changed, 15 insertions, 28 deletions
diff --git a/multimedia/smplayer/smplayer.SlackBuild b/multimedia/smplayer/smplayer.SlackBuild
index 07cc712662..360ff5590d 100644
--- a/multimedia/smplayer/smplayer.SlackBuild
+++ b/multimedia/smplayer/smplayer.SlackBuild
@@ -2,8 +2,8 @@
# Slackware build script for SMPlayer
+# Copyright 2023 Andrzej Telszewski, Koszalin
# Copyright 2011-2015 Fridrich von Stauffenberg <cancellor2@gmail.com>
-# Copyright 2020 Andrzej Telszewski, Szczecin
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=smplayer
-VERSION=${VERSION:-21.10.0}
+VERSION=${VERSION:-23.12.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -42,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -68,30 +65,28 @@ else
LIBDIRSUFFIX=""
fi
-set -e
+set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
+
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
+
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+chmod -R a-st,u+rwX,go-w+rX .
+
+# Disable -Werror (helps building with newer GCC).
-# Disable -Werror (helps building with the newer gcc)
sed -i "s|-W\ -Wall\ -Werror|-W -Wall|" webserver/Makefile
# Fix man page path.
+
sed -i "s/share\/man/man/g" Makefile
make \
- QMAKE=qmake-qt5 \
- LRELEASE=lrelease-qt5 \
PREFIX=/usr \
DOC_PATH="\\\"/usr/doc/$PRGNAM-$VERSION/\\\"" \
QMAKE_OPTS="QMAKE_CXXFLAGS=\"$SLKCFLAGS\""
@@ -111,15 +106,11 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cd $TMP
rm -rf $PRGNAM-themes-$THEMES
tar xvf $CWD/$PRGNAM-themes-$THEMES.tar.bz2
+
cd $PRGNAM-themes-$THEMES
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i "s/rcc -binary/rcc-qt5 -binary/g" themes/Makefile
+chown -R root:root .
+chmod -R a-st,u+rwX,go-w+rX .
make
make install PREFIX=/usr DESTDIR=$PKG
@@ -130,15 +121,11 @@ cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION/themes
cd $TMP
rm -rf $PRGNAM-skins-$SKINS
tar xvf $CWD/$PRGNAM-skins-$SKINS.tar.bz2
+
cd $PRGNAM-skins-$SKINS
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i "s/rcc -binary/rcc-qt5 -binary/g" themes/Makefile
+chown -R root:root .
+chmod -R a-st,u+rwX,go-w+rX .
make
make install PREFIX=/usr DESTDIR=$PKG